Should there be an area to add meta keywords to a page

VERIFIED DUPLICATE of bug 105514

Status

SeaMonkey
Composer
--
enhancement
VERIFIED DUPLICATE of bug 105514
17 years ago
13 years ago

People

(Reporter: TucsonTester2, Assigned: Kathleen Brade)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.3+) Gecko/20010821
Netscape6/6.1b1
BuildID:    20010821

I saw that in the page titles and properties menu that there is no option to add
keywords to the page.  Shouldn't there be an option to add meta keywords in this
or some other menu.

Reproducible: Always
Steps to Reproduce:
1.Open composer
2.Chooses Page Title and Properties in the Format menu

Actual Results:  In this menu there should be an option to add keywords.

Expected Results:  I expect to see in this menu the ability to add in keywords.
 All other meta tags that are created for the composer page are located in this
menu.  So I would expect a text area in here to type in the keywords.

Comment 1

17 years ago
Ahh, I love that idea.  I looked for a duplicate, but found none matching this
request.
   However, I marked this as an RFE (request for enhancement) rather than a
'normal' bug.  Please change it back if you feel otherwise.  (my logic is that
nothing is broken, because it doesn't exist.. etc)
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

17 years ago
can be added by going to html source or by advanced edit dialog (show all tags)
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Reporter)

Comment 3

17 years ago
I understand that and have done that.  One thing is that this is an important
meta tag when submitting a site to search engines.  This is one that should be
used everytime, therefore it should be in the window so that it could be added
with ease.  This is not a tag that is less comonly used like the meta refresh,
this is something used on a regualar basis and is as important as description,
it is something that I expect to see in this menu and use every time.  I can
understand not seeing less used tags, because that is usually for the more
advanced users, but not to have a keywords section is a problem.

Maybe in the future a nice thing to have would be a meta tag generator in the
insert menu or in the page title and properties window.  Instead of having to
type out :

<meta name="Keywords" content="some, bunch, of, junk"> 

There can be a way to just fill out a  name text area and then fill out a
content text area.    In the window it could show what meta tags have been added
into the page.  This would be a much easier way to add meta tags and manage
them.  It could look something like the HTML Attributes window in the advanced
edit of images properties.

Comment 4

17 years ago
spam composer change
Component: Editor: Core → Editor: Composer
(Assignee)

Comment 5

16 years ago
*** Bug 126737 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

16 years ago
duplicating to 105514 which includes meta keywords

*** This bug has been marked as a duplicate of 105514 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.