Closed Bug 973181 Opened 6 years ago Closed 6 years ago

The unprompted elevation mode should be checked only if the user can elevate

Categories

(Toolkit :: Application Update, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla30

People

(Reporter: emk, Assigned: emk)

Details

Attachments

(1 file, 1 obsolete file)

Attached patch patch (obsolete) — Splinter Review
Steps to reproduce:
1. Change the UAC setting to unprompted elevation mode.
2. Log on as a standard user.
3. Launch Firefox.
4. Make sure Firefox is configured to use the maintenance service.
5. Open the About dialog.

Actual result:
UAC prompt will displayed on restart. If the user does not know administrator's credential or if UAC is configured is to auto-deny the elevation request from the standard user, the user can not update.

Expected result:
Updater should use the maintenance service.
Attachment #8376693 - Flags: review?(robert.strong.bugs)
Brian, could you diagnose what could be going on here?
Attachment #8376693 - Flags: review?(robert.strong.bugs) → review?(netzen)
FYI the logic is basically taken from nsXULAppInfo::GetUserCanElevate().
Attached patch patch v2Splinter Review
I removed the check for the "EnableLUA" registry key because it is not only useless but also harmful.
- If UAC is enabled, that's fine.
- If UAC is not enabled, it is impossible for the user token to be TokenUserLimited.
- As the old comment explained, the "EnableLUA" registry key does not reflect the real-time system state.
Unlike "EnableLUA", "ConsentPromptBehaviorAdmin" and "PromptOnSecureDesktop" will be reflected immediately (I tested).
Attachment #8376693 - Attachment is obsolete: true
Attachment #8376693 - Flags: review?(netzen)
Attachment #8376764 - Flags: review?(netzen)
Attachment #8376764 - Flags: review?(netzen) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/ddc85d0fcc98
Assignee: nobody → VYV03354
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/ddc85d0fcc98
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
You need to log in before you can comment on or make changes to this bug.