Closed Bug 973184 Opened 6 years ago Closed 6 years ago

Multiple URLs in geo.wifi.uri

Categories

(Core :: DOM: Geolocation, defect)

30 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: contact, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140215112842

Steps to reproduce:

I am testing Mozilla Location Services in Firefox, so my geo.wifi.uri pref is set to https://location.services.mozilla.com/v1/geolocate/. It works well but only if there is wifi, so it would be nice to be able to specify a second URL as a fallback so if MLS does not return anything, it will try Google Location Services or a simple GeoIP script (https://rudloff.pro/divers/geoip/geoip.php).
Here is a patch that adds support for a geo.wifi.uri.fallback pref.
Blocks: 959987
Component: Untriaged → Geolocation
Product: Firefox → Core
> I am testing Mozilla Location Services in Firefox, so my geo.wifi.uri pref
> is set to https://location.services.mozilla.com/v1/geolocate/. It works well
> but only if there is wifi

Is this still the case for you? MLS supports GeoIP now.
As per my comments in bug 959987, because MLS responds to to everything GLS does, there should no longer be a need for a fallback to GLS.
You're right, I guess this is not needed anymore.
Thanks, closing.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.