Firefox counts the number of times that users pick "Show Original"

RESOLVED FIXED in Firefox 32

Status

defect
RESOLVED FIXED
6 years ago
9 months ago

People

(Reporter: MarcoM, Assigned: mano)

Tracking

Trunk
Firefox 33
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox32 fixed, firefox33 fixed)

Details

(Whiteboard: [translation])

Attachments

(1 attachment, 4 obsolete attachments)

1.  Goal
* As a product owner I want to know how many times users chose to use our translation feature so that we can get a sense of the size of the user problem we are addressing by offering this feature

2.  Acceptance Criteria
* I can view a report that tells me…
** How many times users selected “Translate” on the Infobar
** How many times users selected “No, Thanks” on the Infobar
** How many times users changed language pairs after the initial translation to get a different translation
** How many times they selected “Show Original” 
* This report will be updated weekly
Depends on: 973434
Depends on: 974477
Related or almost a duplicate of bug 973293; I asked some questions there.
What does "changed language pairs" mean in this context? Does this mean that we also need to record the language pair when the user chooses translate in the first bullet point?
Flags: needinfo?(cweiner)
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #2)
> What does "changed language pairs" mean in this context? Does this mean that
> we also need to record the language pair when the user chooses translate in
> the first bullet point?

When the user lands on a page written in a language other than their default language, Firefox will offer to translate it from the language it believes the page to be written in to the user's default language.  We care about assessing the following how well Firefox is detecting the language that the page is written in.  

There are at least two indicators of quality, we think.
1. How many times the user changed the language pair before selecting "Translate" for the first time 
2. How frequently users must try a different pair other than the one initially suggested by Firefox after they have accepted Firefox's initial offer of translation without making changes to the suggested pair.
Flags: needinfo?(cweiner)
Component: Firefox Operations → Client: Desktop
Product: Tracking → Firefox Health Report
Version: --- → Trunk
No longer blocks: fxdesktopbacklog
Flags: firefox-backlog+
Duplicate of this bug: 977733
This isn't prioritized at the moment but bug 978158 will introduce a "recordTranslation()" method which can be used to record this data. Should be very simple to fix.
Hardware: x86_64 → All
(In reply to Marco Mucci [:MarcoM] from comment #0)
> ** How many times users selected “Translate” on the Infobar

Covered by bug 973292.

> ** How many times users selected “No, Thanks” on the Infobar

Bug 977774.

> ** How many times users changed language pairs after the initial translation
> to get a different translation

Bug 977770.

> ** How many times they selected “Show Original”

Seems like this bug should then only be about that last one? We would need another method on the TranslationProvider for that one.
(In reply to Tim Taubert [:ttaubert] from comment #6)
> > ** How many times they selected “Show Original”
> 
> Seems like this bug should then only be about that last one? We would need
> another method on the TranslationProvider for that one.

Did I get that right, Chad?
Flags: needinfo?(cweiner)
Hey Tim, 

If the other requirements are met by the other bugs you mentioned, then yes, we need to address:  

"how many times they selected "Show Original".

Thanks!
Flags: needinfo?(cweiner)
Summary: Firefox counts the number of times that users translate a page → Firefox counts the number of times that users pick "Show Original"
Whiteboard: [story] [translation] → [translation] p=0 [qa?]
Whiteboard: [translation] p=0 [qa?] → [translation] p=0 [qa+]
Whiteboard: [translation] p=0 [qa+] → [translation] p=1 [qa+]
Assignee: nobody → mano
Status: NEW → ASSIGNED
Whiteboard: [translation] p=1 [qa+] → [translation] p=1 s=33.1 [qa+]
Posted patch patch (obsolete) — Splinter Review
One problem: in the browser test, we need to somwhow wait for the telemetry task to finish.
Posted patch patch (obsolete) — Splinter Review
Just a typo after all.
Attachment #8444105 - Attachment is obsolete: true
Attachment #8444283 - Flags: review?(felipc)
Comment on attachment 8444283 [details] [diff] [review]
patch

Oh crap, I forgot I commented out that line :(
Attachment #8444283 - Flags: review?(felipc)
Posted patch patch (obsolete) — Splinter Review
Attachment #8444306 - Flags: review?(ttaubert)
Posted patch patch.diff (obsolete) — Splinter Review
Attachment #8444283 - Attachment is obsolete: true
Attachment #8444306 - Attachment is obsolete: true
Attachment #8444306 - Flags: review?(ttaubert)
Attachment #8444308 - Flags: review?(ttaubert)
Posted patch patch.diffSplinter Review
Attachment #8444308 - Attachment is obsolete: true
Attachment #8444308 - Flags: review?(ttaubert)
Attachment #8444314 - Flags: review?(felipc)
Comment on attachment 8444314 [details] [diff] [review]
patch.diff

Review of attachment 8444314 [details] [diff] [review]:
-----------------------------------------------------------------

::: services/healthreport/docs/dataformat.rst
@@ +1566,1 @@
>  

A little down below there's the example section where showOriginalContent should also be added.
Attachment #8444314 - Flags: review?(felipc) → review+
Iteration: --- → 33.2
Points: --- → 1
Whiteboard: [translation] p=1 s=33.1 [qa+] → [translation] [qa+]
sorry had to backout this change in https://tbpl.mozilla.org/?tree=Fx-Team&onlyunstarred=1&rev=0b7d0cbaa2bd since one of this 2 patches seems to have caused test failures like https://tbpl.mozilla.org/php/getParsedLog.php?id=42331284&tree=Fx-Team
https://hg.mozilla.org/mozilla-central/rev/205fc57a7d32
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
Comment on attachment 8444314 [details] [diff] [review]
patch.diff

[Approval Request Comment]
Bug caused by (feature/regressing bug #): This bug is part of the automatic translation feature, which we want to A/B with a subset of Aurora 32 users.
User impact if declined: Data about users clicking the "Show original" button won't be collected
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): minimal
String or IDL/UUID changes made by this patch: none
Attachment #8444314 - Flags: approval-mozilla-aurora?
Attachment #8444314 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Whiteboard: [qa-]
Whiteboard: [translation] [qa-] → [translation]
Product: Firefox Health Report → Firefox Health Report Graveyard
You need to log in before you can comment on or make changes to this bug.