Closed Bug 973406 Opened 7 years ago Closed 7 years ago

[Sora][Email] The error message when sending an email because the device is offline / has no network connection should say that and indicate possible user actions. (Not just say generic error.)

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(tracking-b2g:backlog, b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WORKSFORME
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: sync-1, Unassigned)

References

Details

(Keywords: polish)

the latest id: Mozilla build ID: 20140118004002 FFOS: 1.3
 
 DEFECT DESCRIPTION:
  DUT havn't any prompt when data network is closed for sending email.
  REPRODUCING PROCEDURES:
  1,Home->open emal->add an yahoo account successfully
  2,Home->Settings->Cellular &Data->unable "Data connection"
  3,Home->Settings->unable Wi-Fi
  4,compose an email to send ->DUT havn't any prompt ->KO
  EXPECTED BEHAVIOUR:
  It prompt "Send the email need the network connect,PLS open it" or any other
  prompt.
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
What happens on a 1.1 Buri device?
Flags: needinfo?(sync-1)
(In reply to comment #1)
 > Comment from Mozilla:What happens on a 1.1 Buri device?
 > 
 
 Same,it only show "send mail failed",i think it need to prompt "Send the email need the network connect,PLS open it" or any other
Flags: needinfo?(sync-1)
Duplicate of this bug: 979842
Summary: [Sora][Email]DUT havn't any prompt when data network is closed for sending email. → [Sora][Email] The error message when sending an email because the device is offline / has no network connection should say that and indicate possible user actions. (Not just say generic error.)
Duplicate of this bug: 1021979
Duplicate of this bug: 1096159
blocking-b2g: --- → backlog
Triage:
Polish issue. Set to backlog.
Keywords: polish
feature-b2g: --- → 2.2?
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
I think we can call this mooted by send in background.  We display the background-send-pending string if we're offline when sending.  In English, this is: "Network unavailable. Email saved to outbox."
Status: NEW → RESOLVED
feature-b2g: 2.2? → ---
Closed: 7 years ago
Resolution: --- → WORKSFORME
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.