Closed Bug 973523 Opened 11 years ago Closed 11 years ago

[10.6] Firefox not usable with OMTC enabled (browser.tabs.remote=true) - causes a plain white window

Categories

(Core :: Graphics: Layers, defect)

30 Branch
x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 974007
Tracking Status
firefox29 --- unaffected
firefox30 - verified

People

(Reporter: whimboo, Unassigned)

Details

(Keywords: regression, Whiteboard: [qa-automation-blocked][mozmill])

Since a couple of days we are experiencing a major outage of Firefox which gets rendered as a completely white window on OS X 10.6. 

So over on bug 972891 which is about a crash for the recently backed-out MOZCRASH line, Bill asked me for details as what can be seen on OS X 10.6. So I checked with a debug build of his inbound push:

[58727] WARNING: Couldn't init gGlobalContext.: file /builds/slave/m-in-osx64-d-00000000000000000/build/gfx/gl/GLContextProviderCGL.mm, line 284
2014-02-17 01:51:26.707 firefox[58727:8313] invalid pixel format
2014-02-17 01:51:26.707 firefox[58727:8313] invalid context
[58727] WARNING: Failed to create CompositorOGL context: file /builds/slave/m-in-osx64-d-00000000000000000/build/gfx/layers/opengl/CompositorOGL.cpp, line 174
ERROR: Changing compositor from 2 to 1.

As of now this blocks all of our testing for Firefox 30.0 on OS X 10.6.
Here the details of our OS X 10.6 machines:

    Model Name:     Mac mini
      Model Identifier:     Macmini4,1
      Processor Name:       Intel Core 2 Duo
      Processor Speed:      2.4 GHz
      Number Of Processors: 1
      Total Number Of Cores:        2
      L2 Cache:     3 MB
      Memory:       8 GB
     
      Chipset Model:        NVIDIA GeForce 320M
      Type: GPU
      Bus:  PCI
      VRAM (Total): 256 MB
      Vendor:       NVIDIA (0x10de)
      Device ID:    0x08a4
      Revision ID:  0x00a2
      ROM Revision: 3546
      Displays:
    Display Connector:
    Display Connector:
This is a regression from bug 960783 since when the browser.tabs.remote preference is set to true. Starting Firefox with the pref set to false all looks fine.
Blocks: 960783
Blocks: core-e10s
Summary: [10.6] Firefox not usable because of OMTC white screen → [10.6] Firefox not usable with OMTC enabled (browser.tabs.remote=true) - causes a plain white window
What happens when you set layers.offmainthreadcomposition.force-basic to false?
True, of course! Do you have anything not as the default under layers.* ?
The above is tested with a fresh profile, so you can assume no user_prefs are set regarding to e10s and layers.
See bug 974007 for an explanation of we're broken for non-e10s windows with browser.tabs.remote=true (the default now).

I assume it's also broken in e10s windows, which needs to be fixed too.
Matt, do you think this needs tracking at this point if so could you provide some more details on impact to users.
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(matt.woodrow)
Andreea, given that Henrik is on PTO can you please confirm this is resolved?
Flags: needinfo?(andreea.matei)
Took latest Nightly on a 10.6 OS X machine and it works fine, browser.tabs.remote preference being set to true and browser.tabs.remote.autostart to false, by default.
Flags: needinfo?(andreea.matei)
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.