Filter UI: should use 'what filter does' as default filter title

RESOLVED DUPLICATE of bug 457745

Status

MailNews Core
Filters
--
enhancement
RESOLVED DUPLICATE of bug 457745
16 years ago
9 years ago

People

(Reporter: gerv, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Inspired by bug 41719.

Instead of prefilling the filter title with Unnamed Filter, we should leave it
blank and then, if the user clicks to create the filter with a blank title, we
should create a title from what it _does_.

i.e. if the filter is [Sender] [contains] [gerv] the default title should be
"Sender contains gerv". This is far more useful than "untitled filter".

This eliminates the need for a "Ha ha, you didn't set a filter name" checkbox
and improves the default.

Gerv

Comment 1

16 years ago
Nice enhancement.

Comment 2

16 years ago
still valid enhancement request as of dec14 commercial trunk
Severity: normal → enhancement
mass re-assign.
Assignee: naving → sspitzer
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: laurel → filters
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core

Comment 6

9 years ago
I inadvertently entered another bug for this(https://bugzilla.mozilla.org/show_bug.cgi?id=457745), and since I have submitted a patch against the other bug (and am about to submit another patch) I'm marking this a dupe of that, instead of the other way around.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 457745
You need to log in before you can comment on or make changes to this bug.