Closed Bug 973537 Opened 7 years ago Closed 7 years ago

testrun_update never ran testDirectUpdate

Categories

(Mozilla QA Graveyard :: Mozmill Automation, defect)

x86
All
defect
Not set
normal

Tracking

(firefox29 affected)

RESOLVED DUPLICATE of bug 972912
Tracking Status
firefox29 --- affected

People

(Reporter: cosmin-malutan, Unassigned)

Details

Attachments

(1 file)

Attached file update_log.txt
Failed with aurora en-US on Windows xp x86(mm-win-xp-32-4)

This is very weird, because the testDirectUpdate suite of tests was never ran so the tastrun failed to retrieve the "updateStagingPath" from the persisted object. 

>05:01:34 *** Installing build: c:\jenkins\workspace\mozilla-aurora_update\builds\2014-02-14-00-40-03-mozilla-aurora-firefox-29.0a2.en-US.win32.installer.exe
>05:01:42 *** Creating backup of binary: c:\jenkins\workspace\mozilla-aurora_update\data\binary_backup
>05:01:45 *** Application: Firefox 29.0a2 (c:\jenkins\workspace\mozilla-aurora_update\data\binary\2014-02-14-00-40-03-mozilla-aurora-firefox-29\firefox.exe)
>05:01:45 *** Platform: Win 5.1.2600 32bit
>05:01:45 *** Cloning test repository to 'c:\jenkins\workspace\mozilla-aurora_update\data\mozmill-tests'
>05:01:51 *** Updating branch of test repository to 'mozilla-aurora'
>05:01:54 *** Setting update channel to 'aurora'...
>05:01:54 *** Creating profile: c:\jenkins\workspace\mozilla-aurora_update\data\profile
>05:01:58 RESULTS | Passed: 0
>05:01:58 RESULTS | Failed: 0
>05:01:58 RESULTS | Skipped: 0
>05:01:58 *** Execution of test-run aborted: 'updates'
>05:01:58 *** Failed to remove the update staging folder: 'updateStagingPath'
OS: Linux → All
Hardware: x86_64 → x86
The question here is NOT why we haven't removed the updateStagingPath, but why we haven't executed the direct updates at all! Please be aware that if no tests were run, there is no updated persisted object.

Also why has this been filed on Bugzilla and not github? You know that we handle issues there for more than a year now!
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
Summary: testrun_update never ran testDirectUpdate, causing it to fail in removing the "updateStagingPath" → testrun_update never ran testDirectUpdate
Product: Mozilla QA → Mozilla QA Graveyard
As we have seen in the past weeks, this is more a dupe of bug 972912 now.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 972912
You need to log in before you can comment on or make changes to this bug.