Closed Bug 973584 Opened 6 years ago Closed 5 years ago

~2.3% tpaint and ts_paint regression on Windows after enabling exact rooting

Categories

(Core :: JavaScript Engine, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 989414

People

(Reporter: ttaubert, Unassigned)

References

Details

(Whiteboard: [Australis:P-])

In bug 970114 we investigated a few t(s)paint regressions. It turns out that enabling exact rooting regresses tpaint on Windows XP by 2.34% and ts_paint on Windows 8 by 2.29%.

I can imagine that it's very hard to figure out what exactly caused the regression here. Is there anything you can do to fix this? Should we wontfix this bug or are perf regressions tracked anywhere else?

Here is a comparison of talos runs:

http://perf.snarkfest.net/compare-talos/index.html?oldRevs=079258ba3328&newRev=0a16682d582a&submit=true
Flags: needinfo?(terrence)
I didn't check other platforms simply because we were investigating Win XP regressions. There might or might not be the same regression on Mac and Linux.
The 20%+ regression on a11yr_paint should be large enough to be visible on Instruments if it repros on MacOS. It's most likely to be a path in bindings code that was not expected to be hot. I'll try and look at it this week.
Flags: needinfo?(terrence)
Whiteboard: [Australis:P-]
No longer blocks: 970114
Duplicate of this bug: 970114
Ah, looking again, the 20% "regression" is actually an improvement. Looking at charts for the 1-2% tpaint regression on WinXP and Win7, it looks like we've closed most of the gap and are still way ahead of where we were in January. Not sure how I'd even go about investigating this small an impact.
Looks like we're going to be getting a >4% win once bug 989414 lands, so I guess with GGC we've gotten back the initial loss from exact rooting.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 989414
You need to log in before you can comment on or make changes to this bug.