Closed Bug 973591 Opened 10 years ago Closed 1 year ago

irccloud makes idle service come back from idle after 2 to 5 minutes

Categories

(Core :: Widget, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 834343

People

(Reporter: mak, Unassigned)

References

Details

(Whiteboard: [Power:P3][tpi:+])

I was investigating why my profile is having difficulties getting bookmarks backups. I started logging idle service behavior through this snippet of code in the browser console:

let idle = Components.classes["@mozilla.org/widget/idleservice;1"].getService(Components.interfaces.nsIIdleService); [1,2,3,5,7,10].forEach(aTimeMin => { idle.addIdleObserver((undefined, aTopic) => { console.log(aTopic); if (aTopic == "idle") console.log(aTimeMin + " <= " + Math.round(idle.idleTime / 60000)) }, aTimeMin * 60) })

Looks like having irccloud open in a tab breaks idle, after 2 to 5 minutes (this is variable) I see an "active" event, so anything waiting for 10 or more minutes of idle is never executed.

I don't think that content should _ever_ be able to modify the idle status of the browser. I didn't try to check which event caused by the page is enforcing the active status yet.
Since the idleservice has a OS specific implementations, I clarify this was reproduce on Win8.1
Cc-ing Roberto who is working on power consumption, as this may be related.
Blocks: 818399
Flags: firefox-backlog?
This is not a Firefox front-end bug, so not eligible for being in our backlog.
Flags: firefox-backlog? → firefox-backlog-
Blocks: power
Whiteboard: [Power]
Kan-Ru said "While it's bad that content could affect idle status of the browser, I don't think it affects power consumption that much. The only downside is if we throttle some activities (animations, maybe?) when the browser is idle, it won't happen. But we are not throttling based on that currently so I suggest Power:P3."
Whiteboard: [Power] → [Power:P3]
Priority: -- → P3
Whiteboard: [Power:P3] → [Power:P3][tpi:+]
Severity: normal → S3

(In reply to Marco Bonardo [:mak] from comment #0)

Looks like having irccloud open in a tab breaks idle, after 2 to 5 minutes
(this is variable) I see an "active" event, so anything waiting for 10 or
more minutes of idle is never executed.

This is very likely a duplicate of bug 834343 where Windows would occasionally send us a 0px mouse move event (that reset the user idle time). It's likely that this happens when a popup notification appears on screen and then disappears (and Windows is sending Firefox a message to give it a chance to change the mouse pointer when Firefox becomes the front-most window again).

It seems likely that irccloud would cause Firefox to show popup notifications.

Status: NEW → RESOLVED
Closed: 1 year ago
Duplicate of bug: 834343
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.