Closed Bug 9736 Opened 21 years ago Closed 20 years ago

POP: Plain text editor omits msg body when replying to html msg

Categories

(MailNews Core :: Composition, defect, P3)

PowerPC
All
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 10970

People

(Reporter: pmock, Assigned: rhp)

Details

Build Date & Platform Bug Found:
  Mac Seamonkey commercial build (1999-07-12-08) installed on PPC 9600 OS 8.5.1
  Win32 Seamonkey commercial build (1999-07-12-08) installed on win32 Win98

Overview Description:
  Under POP, when using the plain text editor to reply to a HTML message, the
message does not quote the message body.  It quotes the message header only.
This problem occurs on Win32, PPC, and Linux.  The behavior is the same on all
platforms.

Steps to Reproduce:
0) Configure your Pref50.js to use a plain text editor
      user_pref("mail.identity.id1.compose_html", true);
1) Start Apprunner
2) Open Messenger through the component bar or task menu
3) Select a rich text message
   The message should display in the message pane
   (Note: if you do not have a HTML message to quote, use Nova to send you a rich
text message then retrieve and select the rich text message)
4) Click on the reply button
   The message header is quoted but is missing body is missing.

Actual Results:
  It fails to quote the message boday.  The header is the only part quoted.\

Expected Results:
  The entire message should be quoted in the the reply.

Additional Information:
  Under IMAP, the behavior is different.  It quotes the message but adds extra
delimiters (">") to the first line of quoted text.
  I will file a separate bug.
Summary: POP: Plain text editor omits msg body when replying to html msg → POP: Plain text editor omits msg body when replying to html msg
fyi
the Linux build that I tested was 1999-07-12-08.

Also, on the different behavior under IMAP, I have logged bug 9737
Assignee: ducarroz → rhp
reassign to Rich
Status: NEW → ASSIGNED
Target Milestone: M9
I think this is conversion related. Will investigate.

- rhp
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Basically, these both boil down to a problem with HTML - plain/text conversion.
This API is changing to adhear to the new stream converter interface and when
that happens, you will start seeing bodies.

- rhp

*** This bug has been marked as a duplicate of 10970 ***
Status: RESOLVED → VERIFIED
verified as duplicate.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.