Closed Bug 973608 Opened 6 years ago Closed 6 years ago

Firefox Nightly crashes on https site with login/password failing request, steps to reproduce in bug

Categories

(Core :: Networking: HTTP, defect, critical)

30 Branch
x86_64
All
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 973207
Tracking Status
firefox29 --- unaffected
firefox30 - affected

People

(Reporter: pascalc, Unassigned)

References

Details

(Keywords: crash, regression, reproducible)

Crash Data

Steps to reproduce:
1/ go to https://www-demo2.allizom.org/fr/firefox/os/
2/ on this password protected (probably via htaccess) site put click on OK in the dialog box, you don't need to put real credentals.
3/ repeat step 2 five times when the dialog pops up again

expected result: dialog pops up again
actual result: Firefox crashes

crash reports:
bp-11ed1911-c3dc-466b-b767-9f1782140217
bp-5d9baf3c-4c3e-4402-be44-8a8602140217

This is 100% reproducible on my config, tested with a new profile and Firefox Nightly build (Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0)

Built from https://hg.mozilla.org/mozilla-central/rev/2bddbd180d2d
Severity: normal → critical
Keywords: crash
OS: Linux → All
Version: Trunk → 30 Branch
about:crashes point me to bug 973207, I guess we could mark this a dupe
Regession window(m-c)
Good:
https://hg.mozilla.org/mozilla-central/rev/a2939bac372b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140213073022
Bad:
https://hg.mozilla.org/mozilla-central/rev/0f18070eb5d6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140213165317
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a2939bac372b&tochange=0f18070eb5d6


Regession window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2e5a57e18585
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140213095446
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0f18070eb5d6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140213115848
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2e5a57e18585&tochange=0f18070eb5d6

Suspected: bug 905460
Blocks: 905460
Component: General → Networking: HTTP
Keywords: regression
Product: Firefox → Core
Crash Signature: [@ mozilla::net::nsHttpConnection::AddTransaction(mozilla::net::nsAHttpTransaction*, int)]
Keywords: reproducible
thanks for the str - that will help get this relanded - I'll back this out for the moment
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 973207
Please nominate bug 973207 if you feel this issue needs tracking.
You need to log in before you can comment on or make changes to this bug.