Closed Bug 973710 Opened 6 years ago Closed 5 years ago

MP4Reader should call MediaDataDecoder::Drain() on EOS

Categories

(Core :: Audio/Video, defect)

29 Branch
x86_64
Windows 8.1
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla33

People

(Reporter: cpearce, Assigned: cpearce)

Details

Attachments

(1 file)

I forgot to call MediaDataDecoder::Drain() inside MP4Reader::Decode() when EOS is detected. :(
Attached patch PatchSplinter Review
Actually call MediaDataDecoder::Drain() on EOS...
Assignee: nobody → cpearce
Status: NEW → ASSIGNED
Attachment #8456600 - Flags: review?(kinetik)
Attachment #8456600 - Flags: review?(kinetik) → review+
This might be the cause of k17e's bug with the ffmpeg decoder not showing the last four frames?
Not sure. I also see the same thing on Window and filed bug 1039128 to track that. The WMF PDM *does* drain as the MSDN docs recommend, so it's real interesting that the same thing is happening with ffmpeg on Linux.
Good to know! I hit a problem in B2G decode module (bug 941302) which might be related to this. It doesn't show a couple of last frames and stops.  Let me have a check.
Apparently, the compilers we use are pedantic SOBs when warnings-as-errors is turned on.

https://hg.mozilla.org/integration/mozilla-inbound/rev/df330e73a20d
https://hg.mozilla.org/mozilla-central/rev/a59633595bcc
https://hg.mozilla.org/mozilla-central/rev/df330e73a20d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
You need to log in before you can comment on or make changes to this bug.