Closed Bug 973850 Opened 7 years ago Closed 7 years ago

Images are not displayed anymore in link view

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

x86
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 verified)

VERIFIED FIXED
1.4 S2 (28feb)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- verified

People

(Reporter: crdlc, Assigned: crdlc)

References

Details

(Keywords: regression, verifyme)

Attachments

(2 files)

No description provided.
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Depends on: 967277
Keywords: regression
Attached file Patch v1
Attachment #8377500 - Flags: review?(jmcf)
blocking-b2g: --- → 1.3?
Comment on attachment 8377500 [details]
Patch v1

thanks, 

please land once we get a green Travis
Attachment #8377500 - Flags: review?(jmcf) → review+
Hi,

Just including some info about the failing scenario:

Pre-requisites:
* some FB contacts with photo already imported
* some local contacts created

STR:
1. Go to contacts and select a local contact
2. Click on "Link contact"
3. A list of FB friends is shown

Expected:
The list of FB friends include the corresponding contact photo

Actual:
Photo is missing in the list of FB friends (please see screenshot attached)
Merged in master:

https://github.com/crdlc/gaia/commit/3618d765783dd5c5d3d57e3f19a2a344cc165d95
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S2 (28feb)
triage: 1.3+ for regression
blocking-b2g: 1.3? → 1.3+
Comment on attachment 8377500 [details]
Patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Changes in image loader
[User impact] if declined: high. User cannot see friend's images
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Very low
[String changes made]:
Attachment #8377500 - Flags: approval-gaia-v1.3?(fabrice)
(In reply to Jose M. Cantera from comment #6)
> Comment on attachment 8377500 [details]
> Patch v1
> 
> NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to
> better understand the B2G approval process and landings.
> 
> [Approval Request Comment]
> [Bug caused by] (feature/regressing bug #): Changes in image loader
> [User impact] if declined: high. User cannot see friend's images
> [Testing completed]: Yes
> [Risk to taking this patch] (and alternatives if risky): Very low
> [String changes made]:
Hi can you help with what sort of testing was done here ? Did we run any QA automated tests or tested the patch on master(1.4) ?
Flags: needinfo?(crdlc)
Hi, just testing on master
Flags: needinfo?(crdlc)
Requesting QA verification on 1.3, once this is uplifted.
Keywords: verifyme
Attachment #8377500 - Flags: approval-gaia-v1.3?(fabrice) → approval-gaia-v1.3+
(In reply to Cristian Rodriguez (:crdlc) from comment #4)
> Merged in master:
> 
> https://github.com/crdlc/gaia/commit/3618d765783dd5c5d3d57e3f19a2a344cc165d95

Please post the link to master next time instead of your fork.
v1.3: 3df4258b121fb66b4853edb05e68c8c21b18d9d5
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.