Hangul JOHAB page layout problem in Mac/Linux

VERIFIED INVALID

Status

()

Core
Internationalization
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: Teruko Kobayashi, Assigned: Jungshik Shin)

Tracking

({intl, pp})

Trunk
intl, pp
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments)

(Reporter)

Description

17 years ago
This is separated from 88944.  Meta charset works fine. 
However, the Hangul JOHAB page is not displayed correctly in Mac.

In Mac, AppleGothic and Seoul fonts is available for Korean.  I changed font in 
Preferences dialog, but the page is not displayed correctly.

Do we need to get the different font to display this page?

Tested 8-28-08 Trunk Mac build.
(Reporter)

Comment 1

17 years ago
Created attachment 47422 [details]
Hangul johab page
(Reporter)

Updated

17 years ago
Keywords: intl, nsbranch
QA Contact: andreasb → teruko

Comment 2

17 years ago
Hi Teruko,

What do you mean by Hangul JOHAB pages not being correctly displayed?
Could you attach a screnshot? If only a subset of 11,172 Hangul syllables
are displayed with Apple Gothic/Seoul fonts (and other syllables 
are 'serialized'),
that's fine. That's exactly what Mozilla is supposed to do when
fonts specified for Korean have only 2350 syllables in pre-composed form.

*** Bug 97400 has been marked as a duplicate of this bug. ***
Updating summary.  Adding keywords and OS/Platform -> All/All.  Does this occur
on  Windows?  If so, remove 'pp' keyword.
Keywords: pp
OS: Mac System 9.x → All
Hardware: Macintosh → All
Summary: Hangul JOHAB page layout problem in Mac → Hangul JOHAB page layout problem in Mac/Linux
(Reporter)

Comment 5

17 years ago
This does not happen in Windows.  That's the reason I logged the 2 separate 
bugs for Linux and Mac. 

Comment 6

17 years ago
Teruko,

Could you attach a screenshot (when you are free) so that I can see whether
 my guess is correct or not. If that's correct, I think
there's *nothing* wrong in both Linux and Mac. If in doubt,
you may install any of Korean fonts with the full coverage of
modern Hangul syllables (either in ksc5601.1992-3 encoding or
in iso10646-1 encoding or in johab-x encoding) and set Korean fonts
to one of them and see how JOHAB pages are rendered.

XFree86 4.x comes with one iso10646-1 font with the full coverage of
modern Hangul syllables. But, Mozilla currently doesn't have a way
to distinguish it from the other font with the same XLFD name other
than 'additional-style field'. So, your easiest way to check 
is install Hanterm-fonts (available at http://www.hanterm.org :
encoding of those fonts are 'johab??'.) 


Comment 7

17 years ago
For details on what I meant by 'serialized' rendering of Hangul syllables
(not present in the font as pre-composed glyphs), you can look
at the screenshots and my comment in bug 70550. It's about
rendering of UTF-8 encoded Korean pages, but if my guess is correct,
that should be applied to this case as well. Of course, there's a possibility
that this bug is a completely different issue until it's verified to have
the same cause as bug 70550.

Comment 8

17 years ago
I've just tried the latest nightly build (2001082808) under Linux and
confirmed that my guess is correct. I'm attaching a screenshot.
Anyway, this bug has to be marked as invalid since Mozilla is just
doing what it's supposed to do when font(s) specified for Korean
rendering do/does not have pre-composed glyphs for Hangul syllables
not present in KS X 1001. I don't have a ready-access to MacOS machine,
but IIRC, Seoul/??? fonts shipped with MacOS 9 have only glyphs
for only 2350 modern syllables in pre-composed form so that the situation
should be the same as ksc5601.1987-0 fonts are specified for Korean rendering
under Unix-like OS + X11.
 

Comment 9

17 years ago
Created attachment 47451 [details]
screenshot of JOHAB page rendered with ksc5601.1987-0 font
(Reporter)

Comment 10

17 years ago
Created attachment 47497 [details]
screen shot of the Johab page is rendered with AppleGothic font in mac.
(Reporter)

Comment 11

17 years ago
Created attachment 47499 [details]
screenshot in linux.
(Reporter)

Comment 12

17 years ago
Created attachment 47503 [details]
right screenshot in mac.
(Reporter)

Comment 13

17 years ago
Created attachment 47504 [details]
right screenshot in linux.
(Reporter)

Comment 14

17 years ago
Please ignore my first 2 attachments (8/29/01 10:50 and 8/29/01 11:04). 
I am sorry they are wrong format.

Comment 15

17 years ago
Thank you for posting screenshots.
They confirmed my guess that Mozilla is just doing
what it's supposed to. There's nothing it does wrong.
For moe details, see bug 70550. Also, you may refer
to http://jshin.net/~jungshik/i18n/koencodings.html
To prevent yet another false alarm from ringing
(bug 70550 was the first of them although it bore_
a fruit in terms of ksc5601.1992-3 font encoding support),
I made it clear that this behavior is NOT a bug in
two JOHAB pages linked from there along with a screenshot.

In light of this, could you mark this as invalid? I tried it, but was told
that I don't have enough previliges .
(Reporter)

Comment 16

17 years ago
I mark this as invalid per Jungshik's prevous comment.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 17

17 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.