Closed Bug 974179 Opened 6 years ago Closed 6 years ago

Backout patch to hide menus in editing mode

Categories

(Firefox for Android :: General, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox28 --- fixed
firefox29 --- fixed
firefox30 --- fixed
b2g-v1.3 --- fixed

People

(Reporter: wesj, Assigned: wesj)

Details

Attachments

(1 file)

Bug 956858 added code to not show menus when the phone is in editing mode. This led to the strange circumstances where hardware menu buttons work if your screen looks like:
http://dl.dropboxusercontent.com/u/72157/menu1.png

but not if it looks like:
http://dl.dropboxusercontent.com/u/72157/menu2.png

which leads you to think we're broken. I'm not even sure the designs in bug 965548 would fix the broken feeling but Ian gave the go ahead to do that or back this out.

Filing a new bug for this so its easier to track uplift.
Attached patch PatchSplinter Review
backout patch
Attachment #8377925 - Flags: review?(mark.finkle)
Attachment #8377925 - Flags: review?(mark.finkle) → review+
Comment on attachment 8377925 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 956858
User impact if declined: Confusing behavior of menu
Testing completed (on m-c, etc.): Landed on mc today. This is a backout though.
Risk to taking this patch (and alternatives if risky): Low risk. 
String or IDL/UUID changes made by this patch: none.
Attachment #8377925 - Flags: approval-mozilla-beta?
Attachment #8377925 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/ea5b6c686ce2
Assignee: nobody → wjohnston
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Attachment #8377925 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #8377925 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.