Closed Bug 974260 Opened 6 years ago Closed 6 years ago

potential xpcshell errors in test_ril_worker_icc.js when RILQUIRKS_V5_LEGACY is set to true

Categories

(Firefox OS Graveyard :: RIL, defect, minor)

ARM
Gonk (Firefox OS)
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED
1.4 S2 (28feb)

People

(Reporter: vicamo, Assigned: vicamo)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #960894 +++

In rebasing patches to v1.3 (not v1.3t), two things found and I think they're worthy of a simple follow-up.

First, we use `this.context.ICCContactHelper` in ICCContactHelper member functions like addICCContact, readSupportedPBRFields, readPhonebookField and updateSupportedPBRFields.  That should be replaced by this pointer.

Second, for branches without bug 958773 uplifted, xpcshell reports failure running "test_ril_worker_icc.js" because this time RILQUIRKS_V5_LEGACY equals to true, while one case in that test script has "this.context.RIL.v5Legacy" equals to false.  This is only reproducible when rebasing patches in bug 960894 to v1.3 branch.  However, it's not logically perfect in m-c, so here comes this bug.

Above two issues have been addressed in patches of both v1.3 and v1.3t branch, leaving the only target here is m-c.
Summary: Utilize one single RIL worker in DSDS → potential xpcshell errors in test_ril_worker_icc.js when RILQUIRKS_V5_LEGACY is set to true
Attached patch patchSplinter Review
Good in emulator, now try: https://tbpl.mozilla.org/?tree=Try&rev=7dbbec46713b
Attachment #8378060 - Flags: review?(allstars.chh)
Attachment #8378060 - Flags: review?(allstars.chh) → review+
https://hg.mozilla.org/mozilla-central/rev/0707af6d54c8
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S2 (28feb)
You need to log in before you can comment on or make changes to this bug.