Closed Bug 974301 Opened 8 years ago Closed 8 years ago

Firefox 27.0.1 will not print in windows XP3

Categories

(Firefox :: Untriaged, defect)

27 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 974038

People

(Reporter: paul.badi, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

When I Install firefox 27.0.1 on windows XP sp3 I can't seem to print.


Actual results:

When I go to File and Print (or Ctrl+P), I get a ding sound, and that's it. The print box doesn't even pop up.


Expected results:

The print box is on the computer screen.
Firefox 26 works perfectly. Safe mode of firefox seems to have no impact, nor does reset.

Some users of firefox 27.0.1 on windows XP3 have this problem:
http://forums.mozillazine.org/viewtopic.php?f=38&t=2801993
hello, would you be able to run the mozregression tool to find out when in the cycle between firefox 26 and 27 the error occurred the first time? please see http://mozilla.github.io/mozregression/ for details.

when the issue first occurred in 27 then you can run the mozregression tool with the following arguments --good=2013-08-05 --bad=2013-09-16

then the tool will automatically download and execute nightly builds from this time span - test if the error is present there and type either "good" or "bad" into the mozregression tool until it comes up with a last good and first bad build - this would be the important information that might be needed to understand what's causing the problem.
Flags: needinfo?(paul.badi)
I run the mozregression tool and you can see 2 pictures  of this argument: --good=2013-08-05 --bad=2013-09-16 --bits=32

http://img4.hostingpics.net/pics/239869261.jpg
http://img4.hostingpics.net/pics/651434902.jpg

I don't know if I made mistakes.
Flags: needinfo?(paul.badi)
paul, i am sorry. i think i gave you the wrong timespan, firefox 27 should actually be:
 --good=2013-09-16 --bad=2013-10-29
Ok no problem. I run the mozregression tool with the right timespan:  --good=2013-09-16 --bad=2013-10-29

You can see the results here:
http://img4.hostingpics.net/pics/22765427a1.jpg
http://img4.hostingpics.net/pics/79213017b2.jpg
http://img4.hostingpics.net/pics/20100275c.jpg
ok, sorry that still doesn't appear right (you should get to a bad instance once) - maybe the change didn't land during the regular 27 nightly cycle but was uplifted later.

can you please try with just --good=2013-10-28
thanks! the regression range would be https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f0d6d67fbc1e&tochange=5fc52820456d which is strange because for me as a layman only bug 932100 seems to be remotely plausible to have caused this, but was backed out of firefox 27 in the end...

can you try to replicate the problem when you restart windows in safemode once (with networking enabled)? http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/boot_failsafe.mspx
In reply to philipp from comment #10)
> can you try to replicate the problem when you restart windows in safemode
> once (with networking enabled)?
> http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-
> us/boot_failsafe.mspx

Unfortunately I can't replicate the problem when I restart windows in safe mode with networking enabled. The print box is on the screen when I select File>Print.
a second-hand report from a german community-forum suggests that the issue might be malware related. can you try running scans with the various security tools listed at https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware
Results of the scans with your list of software: no threads found. But Adwcleaner delete this file:

-\\ Mozilla Firefox v27.0.1 (fr)

[ File : C:\Documents and Settings\Wind\Application Data\Mozilla\Firefox\Profiles\0aph1auc.default-187318021438\prefs.js ]
I unsinstall AVAST Antivirus 2014 and I can print save and open a file with firefox 27.0.1. Do you know a good antivirus for windows XP3?
Somebody can change the status of this bug: UNCONFIRMED>>  UNCONFIRMED INVALID?
Thank you for your help.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 974038
You need to log in before you can comment on or make changes to this bug.