Closed Bug 974419 Opened 9 years ago Closed 9 years ago

TSan: data race js/src/shell/js.cpp:5948 main

Categories

(Core :: JavaScript Engine, defect)

x86_64
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 967545

People

(Reporter: decoder, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [tsan])

Attachments

(1 file)

The attached logfile shows a thread/data race (mozilla-central revision file/tsan-trace100.txt) detected by TSan (ThreadSanitizer).

Typically, races reported by TSan are not false positives, but it is possible that the race is benign. Even in this case though, we should try to come up with a fix unless this would cause inacceptable performance issues. Also note that seemingly benign races can possibly be harmful (also depending on the compiler and the architecture) [1].

If the bug cannot be fixed, then this bug should be used to either make a compile-time annotation for blacklisting or add an entry to the runtime blacklist.

[1] http://software.intel.com/en-us/blogs/2013/01/06/benign-data-races-what-could-possibly-go-wrong
I think this is the same problem as in bug 967544, but racing for gTimeoutFunc instead of gTimedOut. gTimeoutFunc is a JS::Value, how would we solve that issue here?
Flags: needinfo?(jdemooij)
(In reply to Andrew McCreight [:mccr8] from comment #2)
> Dupe of bug 967545?

You're right, I don't know why I missed this one in the list... Jan, can you comment in the other bug maybe? Thanks.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 967545
Flags: needinfo?(jdemooij)
You need to log in before you can comment on or make changes to this bug.