Closed Bug 974443 Opened 6 years ago Closed 6 years ago

The WebRTC toolbar button seems broken when the tab using a device is already selected

Categories

(Firefox :: Device Permissions, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30

People

(Reporter: florian, Assigned: florian)

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
Steps to reproduce:
1. Load https://apprtc.webrtc.org/ in a tab. Keep this tab selected.
2. Click "Share selected devices".
3. Click the camera icon that appeared in the toolbar after the search box.
4. Click the "WebRTC Reference App" menu item.

Actual result:
Nothing happens after performing step 4.

Expected result:
Something should happen after the user clicked the menu item.

I discussed this with Boriss, and while we both greatly dislike the current state of this toolbar button, we agreed that the best short term solution is to show the door hanger notification that informs the user about which device is currently used by the page (microphone, camera, or both), and lets the user stop sharing the device(s).

The patch doesn't include a test because testing the webrtc UI is currently (until bug 804611 lands) very difficult (if not impossible), and the patch is trivial anyway.

I verified that the patch works both for regular web pages and social api chat windows.
Attachment #8378370 - Flags: review?(felipc)
Attachment #8378370 - Flags: review?(felipc) → review+
https://hg.mozilla.org/mozilla-central/rev/9da8894c6918
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Keywords: verifyme
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
Mozilla/5.0 (X11; Linux i686; rv:30.0) Gecko/20100101 Firefox/30.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0

Verified fixed on latest Aurora 30.0a2 (buildID: 20140422004001).
Status: RESOLVED → VERIFIED
Keywords: verifyme
Component: General → Device Permissions
You need to log in before you can comment on or make changes to this bug.