Closed Bug 974454 Opened 6 years ago Closed 6 years ago

Allow showing only description in panel image items

Categories

(Firefox for Android :: Awesomescreen, defect, P2)

All
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 31

People

(Reporter: lucasr, Assigned: lucasr)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

Right now we only show description if the title is also present.
Priority: -- → P1
Comment on attachment 8393015 [details] [diff] [review]
Allow showing only description in panel items (r=margaret)

Applied the same behaviour to both image and article views for consistency.
Attachment #8393015 - Flags: review?(margaret.leibovic)
Comment on attachment 8393015 [details] [diff] [review]
Allow showing only description in panel items (r=margaret)

Review of attachment 8393015 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/home/PanelItemView.java
@@ +58,3 @@
>          }
>  
> +        mTitleDescContainer.setVisibility(!hasTitle && !hasDescription ? View.GONE : View.VISIBLE);

Nit: this logic would be clearer to me as (hasTitle || hasDescription : View.VISIBLE : View.GONE)
Attachment #8393015 - Flags: review?(margaret.leibovic) → review+
Priority: P1 → P2
(In reply to :Margaret Leibovic from comment #3)
> Comment on attachment 8393015 [details] [diff] [review]
> Allow showing only description in panel items (r=margaret)
> 
> Review of attachment 8393015 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: mobile/android/base/home/PanelItemView.java
> @@ +58,3 @@
> >          }
> >  
> > +        mTitleDescContainer.setVisibility(!hasTitle && !hasDescription ? View.GONE : View.VISIBLE);
> 
> Nit: this logic would be clearer to me as (hasTitle || hasDescription :
> View.VISIBLE : View.GONE)

Good point, done.
https://hg.mozilla.org/mozilla-central/rev/57dd616a42f6
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
My cat facts add-on breaks without this, maybe we should try uplifting this to beta. Or I could make cat facts only compatible with 31+.
Duplicate of this bug: 1010724
Setting P2 hub bugs to block hub v2 EPIC bug (targeting fx31 release).

Filter on epic-hub-bugs.
Blocks: 1014030
You need to log in before you can comment on or make changes to this bug.