"View Image" missing in context menu for INPUT TYPE=IMAGE

VERIFIED DUPLICATE of bug 77122

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 77122
17 years ago
10 years ago

People

(Reporter: Adam Hauner, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.2+) Gecko/20010827
BuildID:    2001082703

Add ordinary image items to context menu (menu is appearing after right mouse
button) for images, which are submits in forms (for example: <INPUT TYPE="IMAGE"
SRC="img/submit.gif">). They are same part of document as inline images; this
feature is useful for web developers.

Items are: view image, save image, copy image location




a
The code at
http://lxr.mozilla.org/seamonkey/source/xpfe/communicator/resources/content/nsContextMenu.js#261
Should be handling this case.....

Reporter, do you have a testcase in which this fails?
(Reporter)

Comment 2

17 years ago
I'm not sure if it fails, because reported items aren't in context menu in all
cases.

You can look on http://www.centrum.cz/ and try it on the orange submit button
with text HLEDAT or on http://www.mesec.cz/ on brown submit with text JDI in
left column (first form).
No dupes found. Confirming. 

New url: http://hotbot.lycos.com/ (see the "Search" image next to the input field).
Reporter: You are quite modest, but I think this is a real bug (and not RFE).
Severity: enhancement → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: [RFE] 'view image' item in context menu for form inputs with src → "View Image" missing in context menu for INPUT TYPE=IMAGE
Just tried linux build 2001-08-31-08 on:

http://www.centrum.cz/
http://www.mesec.cz/
http://hotbot.lycos.com/
I cannot reproduce this bug on any of those....
Just tried those urls with 2001-08-31-03 on Win2k, and I still see this (and,
that's the very latest build as I write this). Windows-only bug, maybe?
(Reporter)

Comment 6

17 years ago
I was testing a little, so there is summary:
WinNT4  0.9.2+  Gecko/20010827xx  bug   (me when I reporting bug)
WinNT4  0.9.2+  Gecko/2001083103  bug   (me today)
Win98   0.9.3+  Gecko/2001083103  bug   (my friend today)
Win2K   0.9.??  Gecko/2001083103  bug   (Rembrandt)
Win98   0.9.3   Gecko/20010801xx  okay  (my friend today)
Linux   0.9.3+  Gecko/20010830xx  okay  (another my friend today)
Linux   0.9.3?  Gecko/20010801xx  okay  (Boris)
hrm, using 2001.09.04.xx-comm bits, this isn't a problem for me on mac os x or
linux. however, i cannot get a context menu to appear *at all* on winnt for
those buttons.

blake, is this problem for you?

i also wonder if a similar bug already exists...let me search.
Keywords: pp
OS: All → Windows NT
Hardware: All → PC
hm, could this be a dup of bug 77122?
Keywords: pp
(Reporter)

Comment 9

17 years ago
What I reported in this bug looks same as bug 77122, so this is dupe
(developers,  if you agree, mark it as dupe and remember to transfer info about
OS-dependencies  to bug 77122).

BTW is anybody fixing bugs or all great Mozilla developers are just marking
DUPES? =) Somebody should fix all this IMHO trivial bugs... (I could imagine,
how difficult could be fixing bugs like 'New Window Performance' and I'm
watching every day on big count of fixed bugs, but maybe some milestone (M096?)
could be focused on clearing these small bugs).
> Somebody should fix all this IMHO trivial bugs...

Adam, this is a bug about what options appear in a context menu, right?  It's
platform specific.  All the code that decides what options should appear is in
JS, so it's XP.  This means that something is wrong somewhere deep down.  This
is decidedly not a trivial bug....

Oh, and you can read the checkin logs to see what's being fixed.  People
certainly _are_ fixing bugs.  Feel free to fix a few trivial ones yourself. 
It's really not all that hard....
dupping this; will transfer info over to bug 77122 soon...

*** This bug has been marked as a duplicate of 77122 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.