Closed Bug 974902 Opened 7 years ago Closed 7 years ago

[ms] CTRL+a opens page souce instead of selecting all content

Categories

(Mozilla Localizations :: ms / Malay, defect)

defect
Not set
normal

Tracking

(firefox29+ verified)

RESOLVED FIXED
mozilla29
Tracking Status
firefox29 + verified

People

(Reporter: mihaelav, Assigned: syafiq)

References

Details

Attachments

(1 file)

Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0, build id 20140219004002

CTRL+A keyboard shortcut opens the page source instead of selecting all page content

Steps to reproduce:
1. Launch Firefox 29 using the "ms" locale
2. Load a webpage
3. Press CTRL+A

Expected result:
All page content is selected

Actual result:
The page source is opened.

In chrome://browser/locale/browser.dtd file there we have:

<!ENTITY pageSourceCmd.label "Sumber Laman">
<!ENTITY pageSourceCmd.accesskey "a">
<!ENTITY pageSourceCmd.commandkey "a">

<!ENTITY selectAllCmd.label         "Pilih Semua">  
<!ENTITY selectAllCmd.key         "A">  
<!ENTITY selectAllCmd.accesskey       "a">
If the focus is set on an input box, (like google search input), CTRL+A selects all the text in the input
Blocks: 974892
OS: Linux → All
Hardware: x86 → All
CCing Release Management since this is a new locale.
Jeff can you check in with the localization team here on fixing this error?
Flags: needinfo?(jbeatty)
Adding Syafiq.

Syafiq, it looks like this is causing build problems. Could you please make the necessary fix? Thank you
Flags: needinfo?(jbeatty)
Assignee: nobody → creativeneuron8
Blocks: 974458
Hi Jeff & Mihaela 

We already change for ;

<!ENTITY pageSourceCmd.label "Sumber Laman">
<!ENTITY pageSourceCmd.accesskey "a">
<!ENTITY pageSourceCmd.commandkey "a">

To ;


<!ENTITY pageSourceCmd.label "Sumber Laman">
<!ENTITY pageSourceCmd.accesskey "u">
<!ENTITY pageSourceCmd.commandkey "u"> 

Please find on attachment and wait for next commit in pootle to be resolved.
Flags: needinfo?(mihaela.velimiroviciu)
Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0,
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:29.0) Gecko/20100101 Firefox/29.0,
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0,
build id 20140306004001

Verified on the latest Aurora ms builds and the issue is fixed: CTRL/CMD+a selects all the text in the page/input field.
Flags: needinfo?(mihaela.velimiroviciu)
Mihaela, Thanks for testing. Updating the status flag then.
I think this can be marked FIXED based on recent comments. Please correct me if I am wrong.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
As long as we don't know if it has been signed off for beta, we cannot say it is fixed. Also given that we didn't run the ms locale in Mozmill CI, I don't see results in our dashboard.

Muhammed, can you please give us an update?
Status: RESOLVED → REOPENED
Flags: needinfo?(creativeneuron8)
Resolution: FIXED → ---
(In reply to Henrik Skupin (:whimboo) from comment #10)
> As long as we don't know if it has been signed off for beta, we cannot say
> it is fixed. Also given that we didn't run the ms locale in Mozmill CI, I
> don't see results in our dashboard.

That seems like it should be separated from this bug. This bug was about CTRL+A not working properly in ms supported builds and that appears to have been verified fixed in comment 7. We tend to mark a bug fixed as soon as it's been fixed in Nightly and not wait for it to be "fixed across all branches" to mark it resolved.

Why is this bug any different?
Well, if something has been fixed for a locale on mozilla-central or mozilla-aurora, it doesn't mean that it will be part of the official beta. At least not as long the change hasn't been signed off. So please run an ondemand test in Mozmill-CI for the latest ms Firefox 29.0b build, or we wait for Muhammeds feedback.
@Henrik

Please find my latest test run on Mozmill in this link, 
http://mozmill-crowd.blargon7.com/#/l10n/report/b13d116bf1db6c174a7539f94b00f8d9

FYI, an error on result also been fix.
Flags: needinfo?(creativeneuron8)
Hi Muhammad. The tests you have run above are not related to this bug, because l10n tests do not cover this specific issue but the functional tests do. The Mozmill test which was actually failing is the one from bug 974892. 

So I checked the changeset as landed via Pootle on March 1st:
http://hg.mozilla.org/releases/l10n/mozilla-beta/ms/rev/4a9886e944bd

It contains the fixes for this bug. Given the output from https://l10n.mozilla.org/shipping/signoffs/ms/fx29 I assume it has been signed off. Dwayne, can you please check? Thanks.
Flags: needinfo?(dwayne)
Yes, this was signed off with 4a9886e944bd.
Flags: needinfo?(dwayne)
Thanks Jeff. So in that case this bug is indeed fixed.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.