Continuos error messages stream in JavaScript Console

VERIFIED DUPLICATE of bug 85831

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 85831
16 years ago
13 years ago

People

(Reporter: Andrea, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
How to reproduce:

- Open the JavaScript Console
- Type in: var variable = window.open ('file:///path/filename.html')
  where path/filename.html is an existing local HTML file
- Let the new window popup, and then go back to the JS Console
- Close the JS Console
- Reopen the JS Console
- Type in: alert (variable.title)

The JS Console starts to write a never-ending stream of
"Error: this.console.appendItem in not a function
 Source: chrome://global/content/consoleBindings.xml#console-box.init()"
errors and the Mozilla CPU usage skyrockets. Even closing
the JS Console. Even when the JS Console is reopened again
the errors are still continuosly reported.

Closing all Mozilla windows (e.g. pressing Ctrl+Q in Navigator)
closes all the visible windows, but does not make the Mozilla
task die (with the turbo mode turned off), which continues to
have an high CPU usage.

P.S.: I filed this bug to hewitt under the rginda advice
(Reporter)

Comment 1

16 years ago
Oops, I forgot to say I found this problem with Mozilla 0.9.3 release.

Comment 2

16 years ago
confirmed 2001082908 linux

CPU utilization is very high even after closing JS console.  closing all windows
doesn't leave any rogue mozilla-bins, though.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
(Assignee)

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 85831 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.