Launching nested dialogs in one window and then a dialog in another window, then closing first 2 dialogs causes crash.

VERIFIED DUPLICATE of bug 97664

Status

()

VERIFIED DUPLICATE of bug 97664
17 years ago
2 months ago

People

(Reporter: TucsonTester2, Assigned: kmcclusk)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.3+) Gecko/20010828
Netscape6/6.1b1
BuildID:    20010828

While I was entering in a javascript event to change the background color on
mouse over I forgot what the color I wanted to use was.  So I switched back to
the browser and then opened a new composer window and opened the palette, chose
a color and copied and pasted the hex code into the event.  I clicked ok and ok
again and got a gpf in module GKVIEW.DLL

Reproducible: Always
Steps to Reproduce:
1.Open Netscape Browser
2.Open a new composer page using the file menu
3.Insert an image using the image button on the toolbar
4.Highlight the image and click the link button on the toolbar
5.Type in # for the location of the link and click ok
6.Click the link button to bring up the link properties for the toolbar (because
of a bug, you must do it this way)
7.click on the advanced edit button and then choose the Javascript event tab
8.Choose onlclick in the attribute drop down menu
9.Switch to the browser and open a new composer page from here
10.Open the text color box using the text color box on the toolbar
11.Click on any color and copy the hex code
12.Switch back to the other composer window
13.Type in the value field - bgColor=('@')  - Paste your copied hexcode where
the @ is. so it will look something like bgColor=('#006600')
14.click ok and click ok again

Actual Results:  After following the above steps exactly you will receive a gpf
in module GKVIEW.dll

Expected Results:  I expect that I can have both of those windows open and enter
in the event without any problem.  In order for this to work you have to have
the text color window open in the new browser.

Comment 1

17 years ago
-->cmanske
Assignee: brade → cmanske

Comment 2

17 years ago
Wow! This might win a prize for a "very obscure steps to produce a crash"!
But here's a much simpler set of steps:
1. Open new composer window. Type anything. This is "window 1"
2. Click on "New" to create 2nd Composer window, "window 2". Move window so
it doesn't overlap window 1 much.
3. In window 2, click on "HLine" button to insert a horizontal line.
4. Double click on HLine for its Property Dialog.
5. Click on "Advanced Edit" button to bring up nested dialog.
6. Switch back to window 1 and launch any dialog (Image button will do fine)
8. Switch to window 2 and click OK in Advanced Edit dialog, then OK in 
HLine Properties dialog.

The key behavior seems to be launching 2 dialogs in one window, then a dialog
in the first window, then closing the dialogs in 2nd window. Dialog in 
Window 1 must be created after both dialogs in Window 2.

Stack after clicking Ok in the "Unhandled Exception" dialog:
nsViewManager::ProcessPendingUpdates(nsIView * 0x00000000) line 1637 + 7 bytes
nsViewManager::FlushPendingInvalidates(nsViewManager * const 0x0592ef20) line 3829
nsViewManager::ProcessInvalidateEvent() line 3837
nsInvalidateEvent::HandleEvent() line 141
HandlePLEvent(nsInvalidateEvent * 0x05fc1910) line 155
PL_HandleEvent(PLEvent * 0x05fc1910) line 590 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x05916ce0) line 520 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x00880b3a, unsigned int 49333, unsigned int 0,
long 93416672) line 1071 + 9 bytes
USER32! 77e71820()

I can't see how this is Composer specific, so given the stack, assigning to
"View" component.
But I know Danm would love to investigate it!
Assignee: cmanske → kmcclusk
Component: Editor → Views
QA Contact: sujay → petersen
Summary: Netscape crashes with a palette open in another composer window → Launching nested dialogs in one window and then a dialog in another window, then closing first 2 dialogs causes crash.

Comment 3

17 years ago
I can't reproduce this using Mac/2001091311 (0.9.4), because I can't switch to Window 1 
while any dialogs are open. The dialog hoards all focus in Mozilla until dismissed.

Updated

17 years ago
Keywords: crash

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 97664 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
Verified.
Status: RESOLVED → VERIFIED
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.