Closed Bug 975359 Opened 9 years ago Closed 8 years ago

orientation sensor cannot be set by runEmulatorCmd

Categories

(Firefox OS Graveyard :: Emulator, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: slee, Assigned: vicamo)

References

Details

Attachments

(1 file, 3 obsolete files)

For bug 970183, we need this to to auto test.
Assignee: nobody → vyang
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Attached patch test cases : WIP (obsolete) — Splinter Review
Attachment 8384447 [details] [diff] runs but with numerous unexpected failures.  Actually, I got a duplicated "deviceorientation" event at the beginning, and that fails matching test data in every following run.
Attached patch patch (obsolete) — Splinter Review
This patch only adds test case for B2G emulator orientation sensor.  Try https://tbpl.mozilla.org/?tree=Try&rev=069ba3f5eb5d
Attachment #8384447 - Attachment is obsolete: true
Attachment #8384450 - Attachment is obsolete: true
Attachment #8384462 - Flags: review?(jgriffin)
Attachment #8384462 - Flags: feedback?(slee)
Attachment #8384462 - Flags: review?(jgriffin) → review+
Attachment #8384462 - Flags: feedback?(slee) → feedback+
Attached patch patch : v2Splinter Review
Fix comment styles only. See bug 957917 comment 37.
Attachment #8384462 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/f8cc200ee6ec
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.