radioamp.com - series of alerts. javascript menus don't function

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
P3
major
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: David Epstein, Unassigned)

Tracking

Details

(Whiteboard: [DREAMWEAVER][aok], URL)

(Reporter)

Description

17 years ago
Reproduced in Win NS6.1 trunk 20010828 and Mac build 6.1 2001082708.
1. Go to http://www.radioamp.com/ .
2. click on "Product Info" in the top navbar.  
3. click "Listen to our 300+ stations" at the bottom of the left-hand sidebar. 
Result: A series of alert error messages appear, and the tuner windows doesn't
work after that.
Note: In IE5.5, a sidebar of different types of music appears. No alert msgs.
(Reporter)

Comment 1

17 years ago
changed qa contact to depstein. per WRMB, adding topembed keyword.
Keywords: topembed
QA Contact: petersen → depstein

Comment 2

17 years ago
this will be hardly layout there is some browser sniffing behind and this is
some java script stuff.

Comment 3

17 years ago
Hmmm... I don't get the alerts but I agree that this is not layout. It
definitely has to do with possibly faulty JS on this page -- fancy combinations
of divs and layers(?) maybe. I'd suggest someone from evangelism take a first
crack at ensuring that their JS should work in 6.x or not... If it should then
it's js' bug, else it's evangelism. giving to evangelism for investigation.
Assignee: karnaze → bclary
Component: Layout → US English
Product: Browser → Tech Evangelism
QA Contact: depstein → zach
Version: other → unspecified

Comment 4

16 years ago
removing topembed. if you wish to have a product fix motivated, then reassign
this bug to a browser component.
Keywords: topembed
Summary: Get a series of alert msgs at this site. prevents functionality → radioamp.com - Get a series of alert msgs at this site. prevents functionality

Comment 5

16 years ago
Error: uncaught exception: [Exception... "Could not convert JavaScript argument
arg 0 [nsIDOMWindowInternal.opener]"  nsresult: "0x80570009
(NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame ::
http://www.radioamp.com/common/common.js :: <TOP_LEVEL> :: line 183"  data: no]

they assign a null string to a variable named opener. This vaariable is declared
so this should not be an error should it?

jst, is this a DOM 0 error?
Whiteboard: [BROWER BUG?]
|opener| is a property on the window object and it's of type nsIDOMWindow, so
assigning a string into it will throw an exception. And since the |opener|
variable that's defined on the page is defined in top-level script, it won't
override the already defined window.opener. We can fix this in the DOM code if
we really need to, but it won't be very pretty. Let me know if this needs
working around in the DOM code.

Comment 7

16 years ago
ok, make sense. I was wondering if declaring via the var opener would "hide" the
normal window.opener, but it makes sense if it doesn't. Thanks!

Comment 8

16 years ago
heh, they define function opener() {}!

dreamweaver 3.0 code
http://www.radioamp.com/common/mm.js

looks like a privately help company looking to be bought out, only contact info
is for investors. heh. Anyone got a contact for these dw3 users?
Blocks: 51020
Priority: -- → P1
Whiteboard: [BROWER BUG?] → [DREAMWEAVER]

Updated

16 years ago
Whiteboard: [DREAMWEAVER] → [DREAMWEAVER][aok]

Comment 9

15 years ago
Error: uncaught exception: [Exception... "Could not convert JavaScript argument
arg 0 [nsIDOMWindowInternal.opener]"  nsresult: "0x80570009
(NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame ::
http://www.radioamp.com/common/common.js :: <TOP_LEVEL> :: line 183"  data: no]

and

Error: n has no properties
Source File: http://www.radioamp.com/common/mm.js
Line: 15
Severity: normal → major
OS: Windows NT → All
Priority: P1 → P3
Hardware: PC → All
Summary: radioamp.com - Get a series of alert msgs at this site. prevents functionality → radioamp.com - series of alerts. javascript menus don't function

Comment 10

15 years ago
tech evang june 2003 reorg
Assignee: bc → english-us
QA Contact: zach → english-us
fixed
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.