Closed Bug 975811 Opened 6 years ago Closed 6 years ago

Background position in homescreen is not correct

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME
1.4 S2 (28feb)

People

(Reporter: timdream, Assigned: mchang)

References

Details

(Keywords: perf, regression, Whiteboard: [c=handeye p=1 s= u=])

Attachments

(1 file, 1 obsolete file)

The patch in bug 960325 is not complete.

https://github.com/mozilla-b2g/gaia/commit/7540b00be89b65b180817564dfb4b8a0701179ca

All rules in system.css, including |background-size: cover| should be MOVED to homescreen.css. We now have dead code in system.css, and position is not correct for background in homescreen.

STR:

1. switch wallpaper
2. select wallpaper app
3. select the second "fox in the bush" wallpaper

Expected:

1. the wallpaper should be at the same size/position as on the lockscreen
Flags: needinfo?(mchang)
Hmm interesting that it only occurs on that background. On it.
Assignee: nobody → mchang
Status: NEW → ASSIGNED
Flags: needinfo?(mchang)
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Whiteboard: [c=handeye p=4 s= u=] → [c=handeye p=1 s= u=]
Target Milestone: --- → 1.4 S2 (28feb)
Fixes the problem with the fox in the tree background. Interestingly, that was the only background that has the problem.
Attachment #8380807 - Flags: review?(alive)
Comment on attachment 8380807 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/16573

Please remove dead code from system app.

BTW, what if we remove the background and set the background dynamically to avoid the problem: 'we still render the background image' while an app is opened? Does this solve your problem?
Attachment #8380807 - Flags: review?(alive)
(In reply to Mason Chang [:mchang] from comment #2)
> Fixes the problem with the fox in the tree background. Interestingly, that
> was the only background that has the problem.

People can actually load picture of any dimensions as background from Gallery...
With bug 970284 landed, we need the background styles in both the system app and homescreen app. This patch updates the background style in the homescreen app.
Attachment #8380807 - Attachment is obsolete: true
Attachment #8381942 - Flags: review?(alive)
Attachment #8381942 - Flags: review?(alive) → review+
I wonder if the CSS rule will introduce bug 917416 comment 40 (for phones w/o rocket bar enabled)... we probably need a smarter CSS rule.
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #6)
> I wonder if the CSS rule will introduce bug 917416 comment 40 (for phones
> w/o rocket bar enabled)... we probably need a smarter CSS rule.

I mean the background being incorrectly centered when the keyboard is up, not status bar.
Duplicate of this bug: 976948
Given our stability goals, I think this kind of bug found soon after a landing should warrant a back out. We're now 4 days later and we have a reviewed patch so I won't back it out. But for next times, don't be afraid to back things out, people usually thank you (I know, it's weird).
Landed in gaia master - 89950a14ec912d78f44345bd143fab1e0da23804
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
backout - c8d34e6e98d4b99921fda59ddd89f2dcdce201fc

Visual regression, looks weird, investigating.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Backed out for now, things still working. The original visual regression I saw might be a dupe of 971654. 
Reason for backout, please see https://bugzilla.mozilla.org/show_bug.cgi?id=917416#c101
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → WORKSFORME
blocking-b2g: 1.4? → ---
You need to log in before you can comment on or make changes to this bug.