Closed Bug 975894 Opened 6 years ago Closed 6 years ago

sync preferences should listen for weave:service:start-over:finish instead of weave:service:start-over

Categories

(Firefox :: Sync, defect, P2)

defect

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 + fixed
firefox30 --- fixed

People

(Reporter: markh, Assigned: markh)

References

Details

Attachments

(1 file)

Attached patch t.patchSplinter Review
The sync preferences panel listens for weave:service:start-over, but the start-over process hasn't completed when that fires - weave:service:start-over:finish should be used instead.  Without this, the sync preferences panel is a bit "janky" - it resets to a state where the old sync is still enabled before again changing to reflect that FxA is enabled.

This was in an earlier patch but somehow got lost in the various merges.
Attachment #8380401 - Flags: review?(ttaubert)
Attachment #8380401 - Flags: review?(ttaubert) → review+
https://hg.mozilla.org/integration/fx-team/rev/aaf67168e062
Assignee: nobody → mhammond
Status: NEW → ASSIGNED
Priority: -- → P2
https://hg.mozilla.org/mozilla-central/rev/aaf67168e062
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Comment on attachment 8380401 [details] [diff] [review]
t.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): FxA Sync
User impact if declined: The Sync Preferences panel may show incorrect state
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): None
String or IDL/UUID changes made by this patch: None
Attachment #8380401 - Flags: approval-mozilla-aurora?
Attachment #8380401 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.