Mozilla won't start with spoofed useragent with version <5

VERIFIED DUPLICATE of bug 83376

Status

SeaMonkey
Preferences
VERIFIED DUPLICATE of bug 83376
17 years ago
14 years ago

People

(Reporter: Chris Underhill, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3+) Gecko/20010827)
BuildID:    2001082708

If I try to spoof my useragent field by editing user.js in my profile directory,
and I specify a browser version of <5, mozilla will not start and generates an
error,

Reproducible: Always
Steps to Reproduce:
Add/amend the line in user.js

user_pref("general.useragent.override", "Mozilla/4.0 (compatible; MSIE 5.5;
Windows NT 4.0)");

to match what MSIE uses, and then try and start Mozilla

Actual Results:  Mozilla does not start with the following messages in my
terminal window:

INTERNAL ERROR on Browser End: Expected a version > 5! Version = 0

System error?:: Invalid argument

Expected Results:  Mozilla should start.

Setting to Mozilla/5.0  (compatible; MSIE 5.5; Windows NT 4.0) however works fine.
This is a dupe of bug 83376

You can use a spoofed UA String if you disable the Java Plugin..


*** This bug has been marked as a duplicate of 83376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Summary: Mozilla won't start with spoofed useragent with version <5 → Mozilla won't start with spoofed useragent with version <5
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.