compressing mail folders dies with 'Unknown Error 80470002'

RESOLVED FIXED

Status

MailNews Core
Backend
RESOLVED FIXED
17 years ago
10 years ago

People

(Reporter: chris_calabrese, Assigned: Navin Gupta)

Tracking

({dataloss})

Trunk
x86
Windows NT
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Using Moz .9.3, I get 'Unknown Error 80470002' when compressing mail files.

I'm guessing one of the files is corrupt, but it'd be nice to know which one so
I can fix it by hand.

Comment 1

17 years ago
Can you attach the folder data file (found in your mozilla/mail/* directory) as
an attachment here? Do you have any testcase so we can reproduce this bug? Can
you try a later nightly build (downloadable from www.mozilla.org)?

Thanks.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: dataloss
(Reporter)

Comment 2

17 years ago
I can't attach a test case because I don't know which folder is causing the
problem!!!

OK, I feel better now.

I'll try one of the nightly builds and start searching for the offending folder.
 Thanks.
(Reporter)

Comment 3

17 years ago
Never mind, I can't reproduce it any more.  I think it was a .msf file that was
corrupted, since it disappeared when I deleted some of them.  Be nice if the
front-end let me know which file it was, though.  Sigh.

Good news is that this is by far the best mail reader I've ever used, and
perhaps even the most stable (with the stability stuff that went into .9.3 -
before that it was a dog).

Comment 4

17 years ago
dup of bug 97497?

Updated

17 years ago
QA Contact: esther → sheelar

Comment 5

17 years ago
No. I don't think this is dup of bug 97497.
I actually saw this alert one or two times before on IMAP.
But I couldn't reproduce it again......
(Assignee)

Comment 6

17 years ago
You can compact them one by one using right click menu on a folder "Compact This
folder" to find out which one is doing and when you find the folder, try 
deleting the msf file for that folder. Allow it to be built again and then 
try compacting it again. I think it will most probably fix the problem 
(Assignee)

Comment 7

17 years ago
changing component and reassigning to self. 
Assignee: bienvenu → naving
Component: Mail Database → Mail Back End

Comment 8

17 years ago
I have the same problem.

Comment 9

17 years ago
I have the same problem but on Linux (mozilla 0.9.3).
(Assignee)

Comment 10

17 years ago
0.9.3 is old. Please use latest nightly builds.
(Assignee)

Comment 11

17 years ago
Is anyone seeing this on current trunk builds ?
*** Bug 103835 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
reporter,
Is this still a problem on recent builds. Please comment. Are u seeing this on 
newer profiles?  If so please mention the folder name causing the problem.

Comment 14

17 years ago
I had the same problem, but upgrading to 0.9.4 fixed it for me. Have not had a
problem with compressing folders since.
(Reporter)

Comment 15

17 years ago
Problem seems to be fixed as of around .9.4.

Updated

16 years ago
QA Contact: sheelar → esther
(Reporter)

Comment 16

16 years ago
FYI, I haven't seen this happen in quite some time. I _think_ it went away in
0.9.8, but wouldn't swear to it.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.