No keyboard shortcuts for buttons on javascript console

RESOLVED WORKSFORME

Status

Core Graveyard
Error Console
P3
normal
RESOLVED WORKSFORME
17 years ago
7 years ago

People

(Reporter: Jonathan Baron, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3+) Gecko/20010817
BuildID:    2001081715

The buttons on the console cannot be controlled
from the keyboard alone.  (At least I can't figure
out how to do it.)  This is not a major bug but a
very nice missing feature.  (Some buttons have
underlined letters, such as File, but alt-F or ctrl-F
don't do anything.)  True of all builds I've tried.


Reproducible: Always
Steps to Reproduce:
1. Tasks/Tools/JavaScript Console
2. try expected keyboard shortcuts such as alt-f
3.

Actual Results:  no response


Expected Results:  drop down menu or action (such as "clear")
Confirming and marking NEW. The menubar (File, Edit, View, etc) hotkeys do work
for me, though I don't see a way of accessing the buttons through keyboard-alone.

Reporter: You may wish to try a more recent build to see if that helps with your
menubar problems: http://ftp.mozilla.org/pub/mozilla/nightly/latest/

-> All/All
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Summary: no keyboard shortcuts for buttons on javascript console → No keyboard shortcuts for buttons on javascript console

Comment 2

17 years ago
I have no problem using the menus with Alt+letter, but it would be nice to see
the toolbar functionality from the menus, in a similar to editor's view toolbar,
possibly with accelerator keys. Plus there's lots of other keyboard navigation
missing, such as tabbing to the entry or scrolling through the error list.

Comment 3

17 years ago
javascript debugger != javascript console, over to xpapps
Assignee: rginda → pchen
Component: JavaScript Debugger → XP Apps
QA Contact: rginda → sairuh
(Reporter)

Comment 4

17 years ago
I was asked to try a more recent build.  I've been advised never
to try "latest", so I tried 2001083016, the last one before latest.
Still has the same problems.  Ctrl-w doesn't even work to close
the window.  It is possible that it works on some platforms but not
others.  I am using Red Hat Linux 7.1.  Jon Baron

Comment 5

16 years ago
You need to focus the javascript console window first (click anywhere in that
window), then alt works to select the menus, works under win32, sigh. Also, I
just tested macos x, and you also need to focus the window before key commands
(like command-w to close the window) work, double sigh.

-> hewitt since I think he's partly responsible for the js console, but I could
be wrong ;-)
Assignee: pchen → hewitt
(Reporter)

Comment 6

16 years ago
OK.  Alt-f works, etc.  But not
All Errors Warnings Messages | Clear
This is 0.9.4

Jon
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → Future
Component: XP Apps → JavaScript Console
QA Contact: sairuh → jrgm

Comment 7

15 years ago
These all have keyboard shortcuts in 20021229. Fixed?
(Reporter)

Comment 8

15 years ago
Works for me now with 2003010505.  Yes.  Thanks (whoever did it).
Jon Baron (original reporter)
marking so.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey

Updated

8 years ago
Component: Error Console → Error Console
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.