Closed Bug 976175 Opened 6 years ago Closed 6 years ago

Banner appears on top of non-about:home page during session restore on 2.3

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- fixed
fennec 29+ ---

People

(Reporter: Margaret, Assigned: Margaret)

References

Details

Attachments

(1 file)

I ran into this when my session was restoring.
Blocks: home-banner
This looks like the same Android 2.3 issue that's causing bug 976176.
No longer blocks: home-banner, 960359
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 976176
Actually, no, this is a separate issue, but with a similar cause. I'll post a patch here as well.
Assignee: nobody → margaret.leibovic
Blocks: home-banner
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Banner appears on top of non-about:home page → Banner appears on top of non-about:home page during session restore on 2.3
The way the banner currently works is that it is set to VISIBLE as soon as there's text to put in it, but it has an initial translation that prevents it from appearing on the screen. During session restore on post-2.3 phones, this seems to take care of making sure the banner show up, but this solution doesn't appear to work on older phones.

However, it feels like a bug that the home_pager_container view isn't hidden when we load a normal page from session restore, since it's hidden if we navigate to that page normally.
Attachment #8380847 - Flags: review?(lucasr.at.mozilla)
Comment on attachment 8380847 [details] [diff] [review]
Initialize home_pager_container view to GONE

Review of attachment 8380847 [details] [diff] [review]:
-----------------------------------------------------------------

Makes sense.
Attachment #8380847 - Flags: review?(lucasr.at.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/4f3ea4de80fc
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
tracking-fennec: ? → 29+
Comment on attachment 8380847 [details] [diff] [review]
Initialize home_pager_container view to GONE

[Approval Request Comment]
Bug caused by (feature/regressing bug #): snippets and promo banner
User impact if declined: banner will not hide when it should on pre-honeycomb devices
Testing completed (on m-c, etc.): landed on m-c 2/25, tested locally with gingerbread device
Risk to taking this patch (and alternatives if risky): low-risk, tweaks some visibility code
String or IDL/UUID changes made by this patch: none
Attachment #8380847 - Flags: approval-mozilla-aurora?
Attachment #8380847 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.