Closed Bug 976196 Opened 6 years ago Closed 6 years ago

[B2G] Intermittently, the user is unable to unlock their device after timed out

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 980549

People

(Reporter: nkot, Unassigned)

References

Details

Description:
I've seen this issue multiple times during the last 7-10 days but could not find any good STR. Leaving device idle for some time (~5+ min) while having any apps running (Settings or Browser) will cause inability to unlock it. Reboot menu will get unresponsive as well, have to pull out the battery to recover.

Repro Steps:
1) Updated Buri to BuildID: 20140224040201
2) Open Browser app and browse any websites
3) Leave device idle for ~5+ min
4) Press the power button and slide the ">" to unlock device

Actual:
Occasionally, the user won't be able to unlock device, will have to pull the battery out to recover 

Expected:
Always able to unlock device 

Environmental Variables:
Device: Buri master (v1.4), Mozilla RIL
BuildID: 20140224040201
Gaia: ffb527b84594396ed611edf0a8a5a130d60a742f
Gecko: 31113754db3b
Version: 30.0a1
Firmware Version: v1.2-devices.cfg

Notes: it doesn't happen on v1.3

Repro frequency: 2/2 devices, ~ 30%
Sorry, I put the URL to another issue on the wrong bug. Removing it now.
I afraid to mislead here, but this bug started to occur for me starting Feb 18 (bug 974261 was introduced that day and i thought it somehow related). Also, it doesn't have to be Browser app in the background, it was happening when running other apps - music, FM radio, Settings...

When happens, this issue is really bad.. will do my best to investigate it more.
Duplicate of this bug: 967480
Duplicate of this bug: 975984
We first need to get STR before we try to get a regression window - it's currently not possible to determine the window. Although we've had trouble for a while getting a consistent STR, even though multiple people have confirmed this problem.
QA Contact: astole
According to nkot, this hasn't been seen for 2 weeks, so closing as wfm.
Status: NEW → RESOLVED
Closed: 6 years ago
Keywords: steps-wanted
Resolution: --- → WORKSFORME
I just saw this happen yesterday, running latest trunk. I'm sure it's still happening, but is likely a dupe of bug 980549. Duping so we have more information in the open bug.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 980549
You need to log in before you can comment on or make changes to this bug.