Closed Bug 976485 Opened 6 years ago Closed 6 years ago

[bluedroid]Fix sometimes Avrcp 1.3 play status is out of sync

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
1.4 S3 (14mar)

People

(Reporter: shawnjohnjr, Assigned: shawnjohnjr)

Details

Attachments

(3 files, 2 obsolete files)

Sometimes Avrcp 1.3 position bar/play status is out of sync with car kit AVH-X5550BT.
Assignee: nobody → shuang
It seems that GetPlayStatus command is interfered by Position Changed Notification. It's not good.

9,936	CT	12	STATUS			VENDOR-DEPENDENT			Get Play Status	Non-Fragmented		22	 00:00:05.008821	2014/2/25 上午 06:35:58.222975	
9,937	TG	12		CHANGED		VENDOR-DEPENDENT			Register Notification	Non-Fragmented		27	 00:00:00.025387	2014/2/25 上午 06:35:58.248362	
9,938	TG	12		IMPLEMENTED/STABLE		VENDOR-DEPENDENT			Get Play Status	Non-Fragmented		31	 00:00:00.000655	2014/2/25 上午 06:35:58.249017
Whenever, the play status is out of sync. I noticed that log shows bluedroid did not send out get_play_status_rsp. Maybe this is the root cause after enabling bluetooth log.

03-11 07:21:41.507 I/GeckoBluetooth( 2443): UpdatePlayStatus: [AVRCP] Register notification rsp: PLAY_POS_CHANGE, NOTI_CHANGED
03-11 07:21:41.507 I/GeckoBluetooth( 2443): UpdatePlayStatus: [AVRCP] Get play status rsp
03-11 07:21:41.507 W/bt-btif ( 2443): get_play_status_rsp Not sending response as no PDU was registered
03-11 07:21:41.548 I/GeckoBluetooth( 2443): UpdateRegisterNotification: [AVRCP] Register notification rsp: 5 INTERIM
I found the warning message is because at that time, no GetPlayStatus query updated. But somehow, we shall send play status update but we didn't. :(
Summary: [bluedroid]Sometimes Avrcp 1.3 position bar/play status is out of sync with car kit AVH-X5550BT → [bluedroid]Fix sometimes Avrcp 1.3 play status is out of sync
Root cause:
mPlayStatusChangedNotifyType never been updated, which cause play status notification never reached.
Comment on attachment 8389731 [details] [diff] [review]
Bug 976485 - [bluedroid]Fix sometimes Avrcp 1.3 play status is out of sync

Review of attachment 8389731 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me, thanks. :)
Attachment #8389731 - Flags: review?(gyeh) → review+
https://hg.mozilla.org/mozilla-central/rev/f351db5f1189
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S3 (14mar)
You need to log in before you can comment on or make changes to this bug.