Images don't load, alt-text displayed inappropriately

VERIFIED DUPLICATE of bug 12974

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 12974
19 years ago
19 years ago

People

(Reporter: buster, Assigned: Gagan)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Awaiting VERIFIED DUP from engineer., URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
on the left side of this page, I see the text "spacer.gif - 46" and other
similar output, part of the document source that is leaking into the content
model.  Will attach test case...
(Reporter)

Comment 1

19 years ago
Created attachment 864 [details]
copy of URL, in case they change it
(Reporter)

Updated

19 years ago
Component: Parser → Layout
(Reporter)

Comment 2

19 years ago
it's actually the alt-text that's showing through.  makes this page look really
bad, IE and Nav don't show the alt text for this page (presumably because
they're finding the image?)

Updated

19 years ago
Assignee: rickg → kipp

Comment 3

19 years ago
Kipp -- this looks like another alt-text bug in layout. Here's a reduced text
case:

<html>
<body>
<table cellspacing="0" cellpadding="0" border="0" width="90%">
  <tr>
    <td  valign="MIDDLE" ALIGN="RIGHT">
      <IMG SRC="images/spacer.gif" WIDTH="30" HEIGHT="1" BORDER="0"
ALT="spacer.gif - 46 Bytes">
    </td>
    <td>rick</td>
  </tr>
</table>
</body>
</html>

Updated

19 years ago
Whiteboard: MAKINGTEST mindcrime@nccoast.net || mindcrime@webmail.bellsouth.net

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M10
As agreed with Beth, assigning myself as QA contact for all 'alt text' bugs...

Updated

19 years ago
Assignee: kipp → troy
Status: ASSIGNED → NEW

Comment 5

19 years ago
As far as I can tell, we are doing the right thing. If you agree, please close
the bug.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 6

19 years ago
Buster, you're a cracker. Kipp's right, and we're doing what the HTML4 spec says
for images that can't be rendered
(Reporter)

Updated

19 years ago
Summary: HTML source leaking through into document → Images don't load, alt-text displayed inappropriately
(Reporter)

Comment 7

19 years ago
ah, but IE and Nav are perfectly able to load the images, and for some reason
we are not.  When you ran it on the remote page, did you see the alt-text or
the images?  There's no way for me to know whether this is a necko image loading
problem, or a problem with the image frame not properly displaying an image.  I
don't think it's invalid at all, though it may not be layout.  I'll leave that
for you and warren to work out.
I think you should reopen the bug.  I've changed the summary to reflect what's
really going on.

Comment 8

19 years ago
I'm not going to reopen the bug. I have too many other bugs to deal with. There
are already at least one bug assigned against Necko saying that images that
shlould load are not loading. I think we have that covered
(Reporter)

Comment 9

19 years ago
fine.  submitted necko bug 12974.  this one can stay closed.

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Assignee: troy → gagan
Status: REOPENED → NEW

Comment 10

19 years ago
I don't know of any necko bugs about this. I'll let Gagan verify what's going
on.
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: INVALID → DUPLICATE
I'm marking it a dup of bug 12974, which broke out of this bug, since it is
exactly the same URI, the same problem, and bug 12974 was specifically created
to get this bug closed. Bug 12974 isn't just a duplicate of this bug, it is
actually a clone.

gagan: If you agree, please mark this bug verified. Thanks.


*** This bug has been marked as a duplicate of 12974 ***
Whiteboard: MAKINGTEST mindcrime@nccoast.net || mindcrime@webmail.bellsouth.net → Awaiting VERIFIED DUP from engineer.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 12

19 years ago
verified!
You need to log in before you can comment on or make changes to this bug.