Highlighter outline is now a 1px black border

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
11 months ago

People

(Reporter: pbro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
The current highlighter outline in nightly (30) has turned to a 1px black border.

The highlighter outline CSS is as follows:

.highlighter-outline {
  box-shadow: 0 0 0 1px black;
  outline: 1px dashed white;
  outline-offset: -1px;
}

It's been like this for a long time and hasn't changed lately, however it does look like a black/white dashed border on 29 and looks like a solid black border on 30.

Removing the outline-offset fixes the issue.
In 29, the outline does need the -1px offset to be drawn on top of the shadow, but on 30, it doesn't anymore.

So it looks like the css outline offset mechanism has changed in 30.
I don't know whether this is a regression or a wanted change though, so I don't know if we should simply remove the offset in the devtools, or move this bug to the CSS component.
That's because of bug 480888.
(Reporter)

Comment 2

5 years ago
Thanks Paul.
So it means we need to fix our highlighter CSS by simply removing the -1px offset.

(note that in any case, the box-model highlighter should land very soon: see bug 663778)
I'd say let's wait for Bug 663778 to land instead of fixing this now
Depends on: 663778
(Reporter)

Comment 4

5 years ago
The box model highlighter has landed, this bug is now obsolete.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX

Updated

11 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.