Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Missing opengraph in the app page

RESOLVED FIXED

Status

Marketplace
Consumer Pages
P2
enhancement
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: Daniele "Mte90" Scasciafratte, Assigned: mstriemer)

Tracking

Avenir
Points:
---
Dependency tree / graph

Details

(Whiteboard: [repoman][ktlo])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 Iceweasel/29.0a2 (Beta/Release)
Build ID: 20140214004003

Steps to reproduce:

Share the link on the social network (ex: Facebook or Google+)

Example link: https://marketplace.firefox.com/app/ringtone-picker



Actual results:

The image loaded it's the marketplace icon, the title link is Firefox Marketplace and missing a short description of the app.



Expected results:

The image loaded as the app logo, the title link as the name of the app and a short description.


This feature it's very important for share the apps, now it's impossible share correctly the app for a better advertising.

Updated

3 years ago
Status: UNCONFIRMED → NEW
Component: General → Consumer Pages
Ever confirmed: true

Comment 1

3 years ago
Check if the page is a detail page in Django and add the OG tags, problems with caching? Marking as P3.
Priority: -- → P3

Updated

3 years ago
Severity: normal → enhancement

Updated

3 years ago
Duplicate of this bug: 1004107

Updated

3 years ago
Blocks: 1016433

Updated

3 years ago
Assignee: nobody → kngo
Whiteboard: [repoman]

Comment 3

3 years ago
https://github.com/mozilla/zamboni/pull/2596
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 4

3 years ago
Note, we can do this for feed detail pages too.
See Also: → bug 1074966
(Reporter)

Comment 5

3 years ago
when this integration will be present on the official website?
We ship every Tuesdays around noon PST, so, soon.

Comment 7

3 years ago
I'm not seeing the OG tags so there's a bug somewhere.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

3 years ago
Duplicate of this bug: 1084969

Comment 9

3 years ago
Hi all,
I wanted to weigh in, from a marketing perspective, we are now running between 2-3 marketplace marketing campaigns every month, each campaign has a social component (on Facebook). The idea is to expose as many users as possible to apps and app collections and have users share apps with their friends, being able to do so, pointing to a specific app, would be helpful and supportive of marketing efforts.

Thanks!
Kevin: I just tested locally, your code works fine, the problem is at the nginx level.

https://github.com/mozilla-services/svcops-puppet/blob/dev/modules/marketplace/templates/nginx/marketplace.conf#L282

The rule for app detail page is:
 rewrite "^/app/(?![0-9a-f]{8}(-[0-9a-f]{4}){3}-[0-9a-f]{12}/manifest\.webapp$).*" /server.html break;

(Confusing rule - ignore everything inside the parenthesis, because of the '?' - for the detail page, the rule simplifies to "^/app/.*")

That rule rewrites the app detail page url to simply /server.html, so in zamboni, it does not resolve to the detail page url and therefore we never add the opengraph stuff. We should get ops to do a separate rule in nginx just for the detail page that keeps the uri intact ; I don't know if this has other consequences though.
Flags: needinfo?(kngo)

Updated

3 years ago
Duplicate of this bug: 936114

Updated

2 years ago
Severity: enhancement → normal
Priority: P3 → P2

Updated

2 years ago
Blocks: 1135257

Updated

2 years ago
No longer blocks: 1135257

Updated

2 years ago
Blocks: 1135257
Severity: normal → enhancement

Updated

2 years ago
Whiteboard: [repoman] → [repoman][ktlo]
(Assignee)

Comment 12

2 years ago
https://github.com/mozilla-services/svcops-puppet/pull/119
Status: REOPENED → ASSIGNED
Flags: needinfo?(kngo)
(Assignee)

Updated

2 years ago
Assignee: kngo → mstriemer
(Assignee)

Comment 13

2 years ago
Apps now have opengraph data on dev.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.