Closed Bug 977337 Opened 7 years ago Closed 7 years ago

"navigation bar CallHandler > missed call notification > One SIM" is intermittent

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rik, Assigned: kgrandon)

References

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
rik
: review+
Details | Review
This test was introduced in bug 965853.
Since you are going to be investigating this shortly, I have disabled this test on master:
https://github.com/mozilla-b2g/gaia/commit/3a218b11c808971b98f52676569b360eaa537f93
There was some confusion with bug 969280 so I just relanded the test file with that intermittent disabled.

https://github.com/mozilla-b2g/gaia/commit/07883f3cc8371581c95374980538860322a57386
Duplicate of this bug: 978433
Attached file Github pull request
Oops, I did not see this and uploaded a patch in the other bug. From that bug:

I am pretty sure there was a race condition with setTimeout and postMessage as postMessage is asynchronous, and the code within the setTimeout required the postMessage handler to complete first. I think we can solve this by doing setTimeout after the postMessage handler has fired.

Running a large job on travis to verify now.
Attachment #8384113 - Flags: review?(anthony)
Comment on attachment 8384113 [details] [review]
Github pull request

Thanks for finding this! I was swamped in other things.

Do we still need the inner setTimeout? Because we register for message events after the application code, aren't we sure to run after the handler of the application code?

Feel free to land with or without the setTimeout.
Attachment #8384113 - Flags: review?(anthony) → review+
Thanks! We do unfortunately still need the setTimeout - I believe we need it for the webapps domRequest which happens in the postMessage listener. Landing with it included for now,but someone can always try to remove it later.

Landed: https://github.com/mozilla-b2g/gaia/commit/bbfa35afff01b1ecfbd856496cc888c1b12be736
Assignee: anthony → kgrandon
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.