Closed Bug 977393 Opened 6 years ago Closed 6 years ago

Fix build failure on gonk KK

Categories

(Core :: Graphics: Layers, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla30

People

(Reporter: sotaro, Assigned: sotaro)

References

Details

Attachments

(1 file)

Change of Bug 957323 breaks gonk KK build.
Waiting a confirmation.
There is still no test for gonk KK on tryserver. Then the build on gonk KK was not checked :-(
Comment on attachment 8382670 [details] [diff] [review]
patch - Fix build failure on gonk KK.

peter, can you review the patch soon?
Attachment #8382670 - Flags: review?(pchang)
Attachment #8382670 - Flags: review?(pchang) → review+
I think we should add gonk KK on tryserver soon, do you know who should we contant to?
(In reply to peter chang[:pchang][:peter] from comment #5)
> I think we should add gonk KK on tryserver soon, do you know who should we
> contant to?


Yeah, it is necessary. I do not know about it.

And I just recognized that nexus-5 is almost useless because of Bug 965945's regression... gonk KK on tryserver is definitely necessary.
mwu, do you know who is a correct person to ask adding gonk KK on tryserver?
Flags: needinfo?(mwu)
chris, are you the right person to add gonk KK on tryserver?
Flags: needinfo?(catlee)
Assignee: nobody → sotaro.ikeda.g
https://hg.mozilla.org/mozilla-central/rev/dfcedba04664
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
(In reply to peter chang[:pchang][:peter] from comment #5)
> I think we should add gonk KK on tryserver soon, do you know who should we
> contant to?

It seems better Flatflsh(4.2) build is also on tryserver. Flatfish build is also broken. I recognize that by receiving a mail about it.
(In reply to peter chang[:pchang][:peter] from comment #9)
> chris, are you the right person to add gonk KK on tryserver?

we have very few device builds on try server for legal reasons. is there an emulator-kk target?
Flags: needinfo?(catlee)
(In reply to Chris AtLee [:catlee] from comment #12)
> we have very few device builds on try server for legal reasons. is there an
> emulator-kk target?

Yes.

I think we'll want emulator-kk builds on more than just try though - 1.4 brings in kk support.
Flags: needinfo?(mwu)
You need to log in before you can comment on or make changes to this bug.