--enable-shared-js broken by WeakMapPtr visibility

RESOLVED FIXED in mozilla34

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sfink, Assigned: goughostt)

Tracking

unspecified
mozilla34
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [js:p2])

Reporter

Description

5 years ago
http://people.mozilla.org/~sfink/data/link.log

JS::WeakMapPtr is declared with JS_PUBLIC_API. But it's a template, which perhaps matters. I don't know how to fix it.
Whiteboard: [js:p2]

Comment 1

5 years ago
I confirm that, when trying to build Xulrunner (Firefox-30.0), Linux.

Please, let me know if you want the log.

Updated

5 years ago
Duplicate of this bug: 1034798
Assignee

Comment 3

5 years ago
This works:

  sed -i '/^template class/s/JS::WeakMapPtr/JS_PUBLIC_API(&)/' \
    ./js/src/vm/WeakMapPtr.cpp
https://hg.mozilla.org/mozilla-central/rev/c64aa77208a6
Assignee: nobody → goughostt
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
You need to log in before you can comment on or make changes to this bug.