MailNews Toolbar: Buttons are Misaligned & Graphic at left of Icons is Missing

RESOLVED WORKSFORME

Status

Core Graveyard
Skinability
--
major
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Peter Lairo, Assigned: David Hyatt)

Tracking

({regression})

Trunk
mozilla1.0.1
x86
Windows NT
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.3+) Gecko/20010830

Messenger Toolbar Icons are all messed up (e.g., squezzed together)

- The "letter" graphic is gone
- the icons are too close together- print and stop icons don't display
- etc.
see screenshot...
(Reporter)

Comment 1

16 years ago
Created attachment 47792 [details]
I sure hope this is *not* the new look for the messenger toolbar ;)
(Reporter)

Updated

16 years ago
Keywords: mozilla0.9.4, regression, ui
*** Bug 97747 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

16 years ago
oops, a restart didn't fix it, but then a theme switch did -> invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 4

16 years ago
I fail to see why this is invalid. I'm seeing this with 2001090703 Win2k
(switching themes fixed this as well). Reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

16 years ago
*** Bug 98982 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
Confirming on 2001090703 Win2k.

Screenshot from the duplicate bug:
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=48789

From bug 98982 as well:

One time after starting up Mozilla, the MailNews button bar was horked (see
screenshot). Restarting did not help, but re-changing themes put everything ok
again.

Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

16 years ago
Looks like it's all misaligned, ugh.

Probably a regression from sspitzer/hewitt CSS landing?

Anyways, this is a themes problem. Moving over.
Assignee: sspitzer → hewitt
Component: Mail Window Front End → Themes
Product: MailNews → Browser
QA Contact: esther → pmac
Summary: Messenger Toolbar Icons are all messed up (e.g., squezzed together) → Mailnews toolbar: buttons are misaligned

Comment 8

16 years ago
*** Bug 98099 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
*** Bug 99967 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
*** Bug 100033 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
A complete cleanup of the system (deleted the program directory, every entry in
the registry that contained the word "mozilla", C:\Documents and Settings\User
Name\Application data\Mozilla\*) and reinstall of 0.9.4 seems to help.

Updated

16 years ago
Blocks: 99914
(Reporter)

Comment 12

16 years ago
Deleteing everything is fine, BUT not the user profile. Mine is VERY large and
would take a lot of time to reconstruct. 

Is it possible to narrow down the cause a bit, to isolate the file(s) that
*need* to be deleted?

Comment 13

16 years ago
I am sorry, I am afraid it is not possible to narroy it down. I was to lazy to
delete one part at a time so I did everything right away. Since the problem does
not occur anymore I can not recreate it to test it. Why don't you try to do one
part at a time and see wether it still happens?

Comment 14

16 years ago
try localstore.rdf
(Reporter)

Comment 15

16 years ago
I uninstalled Mozilla (control panel: add/remove), deleted *all* files in the
mozilla directory, and deleted *localstore.rdf* from my profile directory.

Unfortunately, the MailNews toolbar buttons are *still misaligned*.
Keywords: mozilla0.9.4 → mozilla0.9.5
Summary: Mailnews toolbar: buttons are misaligned → MailNews Toolbar: Buttons are Misaligned & Graphic at left of Icons is Missing

Comment 16

16 years ago
*** Bug 100299 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 17

16 years ago
This is, like, sooo fixed after manually deleting the \chrome directory contents
in my profile. ;)

It should never have been able to happen like this in the first place, though.

Comment 18

16 years ago
*** Bug 100481 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 19

16 years ago
I take that back. The *messed-up icons are BACK* after some use and some
reboots, despite my deleting the \chrome directory contents in my profile. :( :( :(

Comment 20

16 years ago
Created attachment 49919 [details]
Image juxtaposing modern, 'shrunken', and classic icon toolbars

Comment 21

16 years ago
I'm getting this intermittently on 2001091303 (0.9.4) on W2k, but haven't been
able to narrow down a reproduceable sequence.  Resetting the theme to modern,
then exiting and restarting (not quick-launch) fixes it.  Possible clues:
 o the shrunken icons, where they appear, are the classic icons, but on the
modern background (see attachment)
 o It only seems to happen after being in use a while (not a fresh mozilla), so
memory consumption is large (>50MB).  Often it appears after a quick-launch that
takes longer than usual, with a period of 100% cpu --- maybe garbage collecting?
 o I've just started getting this with 0.9.4, which is the first release with
quick-launch on by default.

Comment 22

16 years ago
> o I've just started getting this with 0.9.4, which is the first release with
> quick-launch on by default.

I have never seen this with 0.9.3 even with quick launch activated. IMO this is
a problem only with 0.9.4.

Comment 23

16 years ago
> o I've just started getting this with 0.9.4, which is the first release with
> quick-launch on by default.

I mentioned that because I had been using some of the nightly builds since the
20010830 build the original reporter reported against, but without turning on
quick-launch.  I never saw the shrunken icons until I installed 0.9.4, and the
icons have sometimes appeared shrunken thereafter after a quick-launching.   It
may or may not be relevant.

Comment 24

16 years ago
I have been seeing this problem well before 0.9.4 was released.  Cannot remember
the first occurance, but it may have been as far back as 0.9.2.  The workaround
that I've been using is to switch themes and exit mozilla(close quicklaunch).
Restart moz then switch back to modern theme and restart again.  Hope this helps.
(Reporter)

Comment 25

16 years ago
Shouldn't something this glaringly ugly have a high "priority" and some "ns"
keywords? If Netscape comes out with a new version and this grotesque appearance
start cropping up, that would be "vely vely baad". I can just see those looser
reviewers fixating on this - because they don't take the time to review for
things that matter.

Comment 26

16 years ago
No it shouldnt because it is not a crash or somehow stops people from using
things. Frankly I am getting tired of your pestering about keywords and adding
keywords to everything, and I am in no mood to discuss your opinions on keywords
and lack of keywords. Now stop cluttering up bugzilla with these type of comments.

Comment 27

16 years ago
*** Bug 100908 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 28

16 years ago
[OT]
Keyser Sosez: uh, "crash" and "loss of function" are SEVERITY issues. I
suggested a higher PRIORITY, which is a level of "importance" to the project,
which is a subjective evaluation. Please get your facts straight before
attacking those who are trying to help.
[/OT]
*** Bug 99292 has been marked as a duplicate of this bug. ***
integrating data from bug 99292

Icons are from the classic skin. Problem appears to be windows-specific, but not
related to turbo.
Joe Hewitt says this is a chrome registry problem.
Keywords: nsbranch

Comment 31

16 years ago
For what it's worth, you don't have to switch to classic, restart, and switch
back to modern again.  (In 9.4, at least,) I start mailnews, see the icons are
messed up, select modern from the View->Apply Theme menu, restart once, and it's
all set.

It's notably odd that selecting the theme that is already apparently selected
should work to fix this problem.

Comment 32

16 years ago
This doesn't fit the latest profile for nsbranch bugs  (crash, data loss, major
feature broken). Assuming this only happens if you install a second theme, and
have switched at least once, nsbranch-.  Feel free to renominate or bring
directly to PDT if this is likely to affect new installs or upgrades directly
from 6.1.
Keywords: nsbranch → nsbranch-

Comment 33

16 years ago
Messing up the icons happens to my Mozilla 2001091303 once in a while, but I am
using the modern theme as the only theme as long as it exists.
Indeed, reselecting the modern theme and restarting fixes it. Does it have to do
with the quick launch option. I use this one for the first time now and since
then the icons are messed up.
(Reporter)

Comment 34

16 years ago
RE "nsBranch": I think this happens every time I install a new nightly.
Therefore, users of N6.1 will likely see this ugly little critter when they
upgrade from N6.1.

Comment 35

16 years ago
I don't see where this rumor that Mozila must be reinstalled in order to see
this bug got started, but in my case (at least) I'm getting this problem
installing the 9.4 release on a fresh win2000pro machine that's never had
anything other than IE on it (poor thing).  So no reinstallation was necessary
to produce this bug.

Comment 36

16 years ago
Re: "Assuming this only happens if you install a second theme, and
have switched at least once, nsbranch-.  Feel free to renominate or bring
directly to PDT if this is likely to affect new installs or upgrades 
directly from 6.1."

Assumption may not hold:  I did not 'install' any additional themes (though note
there are 2, modern and classic).   I did not switch themes before this problem
appeared.

Comment 37

16 years ago
I reckon this is a chrome registry problem, not a themes problem.
Assignee: hewitt → hyatt
Component: Themes → Skinability

Comment 38

16 years ago
It is worth noting that, while this is a problem with both mailnews and
addressbook, the browser's and composer's toolbars are never effected.
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0

Comment 39

16 years ago
I've just noticed that this seems to happen if you've closed all brower windows
first, then close the mail/news window.  This is in Windows95, Build 2001091303
(0.9.4).
*** Bug 102840 has been marked as a duplicate of this bug. ***

Comment 41

16 years ago
*** Bug 105350 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Blocks: 107067

Updated

16 years ago
Keywords: nsbranch-
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 42

16 years ago
Why has the target milestone been pushed to 1.0.1?  According to the 1.0
manifesto, "Our reputation is at stake precisely because 1.0 is such a coveted
and feared version number."  Do we want our reputation to be based on a faulty,
ugly, and just plain buggy looking mailnews client?  why 1.0.1 and not 1.0 (or
9.6 for that matter)?

Comment 43

16 years ago
This has never occured to me and worksforme.  Is there a reproducible testcase
for how to reproduce it on a current build?

Comment 44

16 years ago
I have got the error when using the quick launch option on my windows 2000
machine together with the stand-by option. Since then I have turned off the
quick launch option. I did not retry it with the latest build yet.

Comment 45

16 years ago
Maybe this could be a hint: I've installed 0.9.5 on my win98. I have installed
it in a fresh directory, but I'm still using an old profile. I'm using
quick-launch. Also I have installed several add-ons (calculator, games,
toolbars...). And I am seeing this bug.

I've also installed 0.9.5 on my father's computer (NT4). His computer has only
seen Netscape 6.0 and maybe an older version of Mozilla. I haven't installed any
add-ons and I also configured quick-launch. His profiles aren't fresh either,
but probably not as old as mine (back to M18).

Probably we should all check if this also happens if we install it again from
scratch. - I don't like that because migrating profiles is a headache...

Comment 46

16 years ago
Build-ID "2001101117" on Win2k: layout problem occurred after a few times usage
(fresh install; old profile restored; Quick Launch enabled). Reapplying Modern
theme followed by a restart of Mozilla fixed the problem.

Comment 47

16 years ago
*** Bug 107674 has been marked as a duplicate of this bug. ***

Comment 48

16 years ago
I used to have this bug, but it disappeared with build 20011031, a nightly from
3rd October. Regards

Comment 49

16 years ago
Has anybody had this problem in recent versions?  It seemed to disappear for me
after installing 0.9.5.  Seeing as we're at 0.9.6 and truckin' on, if no one can
say they've seen this bug I move we mark it as fixed.

Comment 50

16 years ago
I haven't seen this bug either in the last few weeks.

Comment 51

16 years ago
I still had this bug with 0.9.5 but with 0.9.6 (installed today and played with
extensivly) it seems to disappear. I am not using any nightlies so it might have
disappeared earlier.

Comment 52

16 years ago
So let's take the initiative to resolve it :) There are lot of new bug reports
for 0.9.6 but no dupes of this one. Marking as WORKSFORME.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.