Closed Bug 977954 Opened 7 years ago Closed 7 years ago

CustomizableUI tests fail on Win8 when not built with --enable-metro

Categories

(Firefox :: Toolbars and Customization, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 978127

People

(Reporter: Unfocused, Assigned: Unfocused)

References

Details

Jared noticed that our CustomizableUI tests fail on Win8 when the build hasn't been built with --enable-metro. AFAIK, the build slaves always build on Windows with --enable-metro. I'd guess that many contributors wouldn't add --enable-metro, and generally shouldn't need to unless they're working on that (it adds unneeded time to the build process). So we should fix that sooner rather than later.
Specifically this is because the Switch To Metro button is not added to the menu panel unless --enable-metro is defined, and many of the tests check the runtime environment to determine if the button should be present.
See Also: → 978127
Depends on: 978127
Hmm, shouldn't the Services.metro test catch this cas?

http://mxr.mozilla.org/mozilla-central/source/toolkit/modules/Services.jsm#88
(In reply to Jim Mathies [:jimm] from comment #2)
> Hmm, shouldn't the Services.metro test catch this cas?
> 
> http://mxr.mozilla.org/mozilla-central/source/toolkit/modules/Services.jsm#88

ah, nm, this is caused by bug 978127. That catch does work, but the customized ui tests aren't up to date.
No longer blocks: australis-cust
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
No longer depends on: 978127
Resolution: --- → DUPLICATE
Duplicate of bug: 978127
You need to log in before you can comment on or make changes to this bug.