Closed Bug 978003 Opened 6 years ago Closed 6 years ago

Update inContentUI.css for Windows 8 and up

Categories

(Toolkit :: Themes, defect)

All
Windows 8.1
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: Terepin, Assigned: dao)

References

Details

(Whiteboard: [Australis:P4])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140227030203

Steps to reproduce:

ICUI has still Aero theme, which looks out of place, now even more since bug 960517 landed. This bug is about "about" pages in general. I will fill separate bugs for each "about" page if needed.
Component: Untriaged → Theme
Depends on: 960517
Hardware: x86_64 → All
Status: UNCONFIRMED → NEW
Component: Theme → Themes
Ever confirmed: true
Product: Firefox → Toolkit
Summary: In-Content UI (ICUI) themes adjustments for Windows 8 and up → Update inContentUI.css for Windows 8 and up
Assignee: nobody → dao
Blocks: australis, 960517
No longer depends on: 960517
Whiteboard: [Australis:P4]
Attached patch patchSplinter Review
Attachment #8386044 - Flags: review?(mdeboer)
Comment on attachment 8386044 [details] [diff] [review]
patch

Review of attachment 8386044 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM. Thanks Dão!

I didn't know about the `-moz-windows-glass` media query (not consciously, at least)... handy!
Attachment #8386044 - Flags: review?(mdeboer) → review+
https://hg.mozilla.org/mozilla-central/rev/c368136afb26
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Comment on attachment 8386044 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 960517
User impact if declined: visual mismatch on Windows 8
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8386044 - Flags: approval-mozilla-aurora?
Dao, add-ons list and section selector should be squared and not rounded. Shall I fill bug for it?
Peter, that is a good idea. This bug is about adjusting the general styles used across in-content pages. The UI element of specific pages are not considered part of this bug. It's going to be a lot of work, but each in-content page will need to be reviewed and adjusted separately. A bug should be filed for each of them.
(I meant that filing a bug is a good idea)
Is "squaring" a valid English word? :)
As far as I'm concerned, it is now! :)
Depends on: 980339
Filled. Please, review it and I'll fill rest of the reports accordingly. Thanks.
Eh, are there plans to restyle about:support?
Blocks: 980413
Blocks: 980418
Attachment #8386044 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Blocks: 980339
No longer depends on: 980339
With this bug fixed, the addon buttons (Disable, Remove,...) have the native styling on Windows 8. Not sure if that is expected.
Dao, can you confirm if Tim's results are expected or not?
Flags: needinfo?(dao)
I think that's expected. Using the native, flat and square button styling is in line the other Win 8 theme adjustments in inContentUI.css and elsewhere.
Flags: needinfo?(dao)
In that case I'm marking this issue verified. Thank you!
# Fx 29 beta 8: 20140414143035
# Latest Aurora: 20140416004008
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.