Closed Bug 978072 Opened 6 years ago Closed 6 years ago

update mozilla domain for social activations

Categories

(Firefox Graveyard :: SocialAPI, defect)

28 Branch
x86
macOS
defect
Not set

Tracking

(firefox28+ fixed, firefox29+ fixed, firefox30+ fixed, b2g-v1.3 fixed)

RESOLVED FIXED
Firefox 30
Tracking Status
firefox28 + fixed
firefox29 + fixed
firefox30 + fixed
b2g-v1.3 --- fixed

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file, 1 obsolete file)

change the social.directories pref to point to activations.mozilla.org.  The  pref is in all.js
Attached patch update social.directories pref (obsolete) — Splinter Review
Assignee: nobody → mixedpuppy
Attachment #8383655 - Flags: review?(felipc)
Comment on attachment 8383655 [details] [diff] [review]
update social.directories pref

Review of attachment 8383655 [details] [diff] [review]:
-----------------------------------------------------------------

::: modules/libpref/src/init/all.js
@@ -4463,5 @@
>  // comma separated list of domain origins (e.g. https://domain.com) for
>  // providers that can install from their own website without user warnings.
>  // entries are
>  pref("social.whitelist", "https://mozsocial.cliqz.com,https://now.msn.com,https://mixi.jp");
>  // omma separated list of domain origins (e.g. https://domain.com) for directory

can you fix the typo in the comment together?
Attachment #8383655 - Flags: review?(felipc) → review+
comment fixed
Attachment #8383655 - Attachment is obsolete: true
Attachment #8383743 - Flags: review+
28 is going to be out pretty soon. Please request uplift soon if yo want it in 28 (as the tracking flag suggests)
Comment on attachment 8383743 [details] [diff] [review]
update social.directories pref

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 957771 activation domain for social providers
User impact if declined: unable to activate from domain where snippet promotions will point to
Testing completed (on m-c, etc.): manual testing on fx-team
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none
Attachment #8383743 - Flags: approval-mozilla-beta?
Attachment #8383743 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/1de38e0fbbb6
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Attachment #8383743 - Flags: approval-mozilla-beta?
Attachment #8383743 - Flags: approval-mozilla-beta+
Attachment #8383743 - Flags: approval-mozilla-aurora?
Attachment #8383743 - Flags: approval-mozilla-aurora+
Whiteboard: [qa-]
Whiteboard: [qa-]
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.