Closed Bug 978131 Opened 6 years ago Closed 6 years ago

[Australis] Legacy toolbar button labels misaligned in menu panel

Categories

(Firefox :: Theme, defect)

29 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- fixed

People

(Reporter: alexander, Assigned: Gijs)

References

Details

(Whiteboard: [Australis:P3-][good first verify])

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140218135856

Steps to reproduce:

I have an extension containing two XUL toolbarbuttons in a toolbaritem:
https://addons.mozilla.org/firefox/addon/cookie-whitelist-with-buttons/

In the Australis menu panel, the icons are aligned correctly, but the labels are placed too high. The attached screenshot shows customization mode so I could take a screenshot, but the live menu panel looks the same.

When the buttons are moved to the palette, the labels seem to be aligned correctly.
If there are two buttons inside a single toolbaritem, I expect that that'll need work from you in order to work correctly - what happens if you put the item after a row of 2 single items?
You mean like "button button blank extension button? It's still misaligned.
(In reply to Alexander Dietrich from comment #2)
> You mean like "button button blank extension button? It's still misaligned.

Yes, but the problem is that there's a blank at all. We're trying to avoid that happening in the first place.
Ok, I will try to install the buttons individually for Australis and report back.
Yes, without the toolbaritem wrapping the buttons, the labels line up as expected.

I can live with that, if buttons are expected to be movable individually in Australis. I'll change the extension accordingly.

Thanks!
(In reply to Alexander Dietrich from comment #5)
> Yes, without the toolbaritem wrapping the buttons, the labels line up as
> expected.
> 
> I can live with that, if buttons are expected to be movable individually in
> Australis. I'll change the extension accordingly.
> 
> Thanks!

Excellent! However, we on our side should probably still fix the buttons to not have that outlining problem (because some people might have a single toolbarbutton inside a toolbaritem, for instance). I'll try to look at this this weekend or the coming week.
Component: Untriaged → Theme
Flags: needinfo?(gijskruitbosch+bugs)
We don't auto-set the wrap attribute on nested toolbarbuttons, and so they don't get all the styling for free. At least this (the vertical sizing) we can fix. Not an issue on OS X because the labels have the right margin to begin with.
Attachment #8385031 - Flags: review?(mconley)
Assignee: nobody → gijskruitbosch+bugs
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(gijskruitbosch+bugs)
Whiteboard: [Australis:P3-]
Comment on attachment 8385031 [details] [diff] [review]
add correct styling for non-wrapped toolbarbutton-1s for the Australis panel,

Review of attachment 8385031 [details] [diff] [review]:
-----------------------------------------------------------------

WFM! Thanks Gijs.
Attachment #8385031 - Flags: review?(mconley) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/d38bceb092b7
Whiteboard: [Australis:P3-] → [Australis:P3-][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/d38bceb092b7
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3-][fixed-in-fx-team] → [Australis:P3-]
Target Milestone: --- → Firefox 30
Comment on attachment 8385031 [details] [diff] [review]
add correct styling for non-wrapped toolbarbutton-1s for the Australis panel,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: add-on provided buttons might not look the same as ours without more work by add-on authors (but only on some platforms, making it hard to notice/fix)
Testing completed (on m-c, etc.): on m-c, locally
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8385031 - Flags: approval-mozilla-aurora?
Attachment #8385031 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [Australis:P3-] → [Australis:P3-][good first verify]
You need to log in before you can comment on or make changes to this bug.