Closed Bug 978147 Opened 6 years ago Closed 6 years ago

g_type_init is deprecated and does nothing

Categories

(Toolkit :: General, defect)

All
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1114898

People

(Reporter: keeler, Unassigned)

Details

Attachments

(1 file, 1 obsolete file)

From https://developer.gnome.org/gobject/stable/gobject-Type-Information.html#g-type-init :

> g_type_init has been deprecated since version 2.36 and should not be used in newly-written code. the type system is now initialised automatically

Unless we need to be able to build with gobject < 2.36 (which doesn't seem to be supported anymore: https://developer.gnome.org/gobject/ ), it seems like we can get rid of some unnecessary things and remove a compiler warning.
Attached patch bug-978147.patch (obsolete) — Splinter Review
Attachment #8384843 - Flags: review?(dkeeler)
Assignee: nobody → mozbugs.retornam
Comment on attachment 8384843 [details] [diff] [review]
bug-978147.patch

Review of attachment 8384843 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, but I'm not a toolkit peer, so I can't r+ this. Marking f+. Someone from https://wiki.mozilla.org/Modules/All#Toolkit should look at this (preferably someone with gnome expertise).

::: toolkit/system/gnome/nsGnomeModule.cpp
@@ +65,1 @@
>  

nit: we probably don't need this extra blank line
Attachment #8384843 - Flags: review?(dkeeler) → feedback+
Attached patch bug-978147.patchSplinter Review
Attachment #8386240 - Flags: review?(netzen)
Comment on attachment 8386240 [details] [diff] [review]
bug-978147.patch

Review of attachment 8386240 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry, I'm not the best person for this review, maybe roc can review or delegate to someone.
Attachment #8386240 - Flags: review?(netzen) → review?(roc)
Thanks Roc.
Keywords: checkin-needed
Backed out in https://hg.mozilla.org/integration/fx-team/rev/082bae16fc33 for apparently breaking Linux mochitests. They're all failing like this: https://tbpl.mozilla.org/php/getParsedLog.php?id=35746723&tree=Fx-Team
Flags: needinfo?(mozbugs.retornam)
Whiteboard: [fixed-in-fx-team]
(In reply to David Keeler (:keeler) from comment #0)
> Unless we need to be able to build with gobject < 2.36 (which doesn't seem
> to be supported anymore: https://developer.gnome.org/gobject/ ), it seems
> like we can get rid of some unnecessary things and remove a compiler warning.

Shoot - I misread that page. It looks like we're using 2.32.1, which is still supported, which does require g_type_init. So, that was a waste of time. My apologies, everyone.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(mozbugs.retornam)
Resolution: --- → INVALID
Assignee: mozbugs.retornam → nobody
Resolution: INVALID → DUPLICATE
Duplicate of bug: 1114898
You need to log in before you can comment on or make changes to this bug.