Bugzilla product description misleading

VERIFIED FIXED

Status

()

VERIFIED FIXED
17 years ago
7 years ago

People

(Reporter: myk, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
The Bugzilla product description says:

---
You're using it! This is the place to report bugs in the Bugzilla bug report
management system. THIS IS NOT THE PLACE TO REQUEST CHANGES TO
BUGZILLA.MOZILLA.ORG.  If you have keyword or component changes or other issues
specifically with bugzilla.mozilla.org, please use the "mozilla.org" product (at
the bottom of the product list).
---

My recommendation: Change "in the Bugzilla bug report management system" -> "on
the Bugzilla bug report management system itself".  The current wording could
imply that this is the Product in which to file bugs.  I don't know what those
users might think the other products are for, but I bet some will think this way.
(Reporter)

Comment 1

17 years ago
Maybe this is a separate bug and I'm being bad, but the Webtools product
description still references Bugzilla.  That should go away:

---
For bugs about the web-based tools that mozilla.org uses. This include Bugzilla
(problems you are having with this bug system itself), Bonsai, and Tinderbox.
---
--->

---
For bugs about the web-based tools that mozilla.org uses. This includes LXR,
Bonsai, and Tinderbox but does not include Bugzilla, which has its own product.
---
Summary: Bugzilla product description misleading → Bugzilla and Webtools product descriptions misleading
The Webtools description already has a bug I filed 3 days ago.  Asa hasn't
touched it yet. (bug 97265)

As for the Bugzilla description, I agree.  That one little word can make a
difference.  We've already had at least one...  remember, don't charge your
pages! :)
Summary: Bugzilla and Webtools product descriptions misleading → Bugzilla product descriptions misleading
Summary: Bugzilla product descriptions misleading → Bugzilla product description misleading
(Reporter)

Comment 3

17 years ago
"You're using it!" might also be too attractive and draw too many eyes in this
direction.
(Assignee)

Comment 4

17 years ago
moving to my component, Bugzilla: Keyword & Component Changes
Assignee: endico → asa
Component: Bugzilla: Other moz.org Issues → Bugzilla: Keyword & Component Changes
QA Contact: myk → timeless
(Assignee)

Comment 5

17 years ago
*** Bug 100155 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

17 years ago
I went with Myk's suggested change. If you want me to do more please reopen this
bug with further suggestions. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
hmm, we're still getting a few...

how about, instead of "you're using it!" something like "Bugzilla is the
web-based bug reporting software in use by the web site you are currently
visiting" or "Bugzilla is the web-based bug reporting engine that you are
currently using."
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 8

17 years ago
Why even mention that the user is currently using Bugzilla?  Why not just say
what it is?
(Assignee)

Comment 9

17 years ago
Being a full grown Product has its disadvantages :)  All of the other Products
get misfiled bugs too. That's the problem with being near the top of the list at
the top if the hierarchy. I can try to make the description more clear but I
don't think it's going to stop Browser bugs from langing in Bugzilla. 
heh, well, it's not a REAL critical thing...  Timeless was trying to verify this
bug, and asked in IRC if everyone was happy with the wording...  I said "well,
maybe it should looks like this instead" and he said "I like that wording,
reopen it and paste that in"

I don't mind too much moving the bugs over (and Jake usually beats me to it). 
Just thought maybe it could be clarified a little more.  Maybe the "don't report
problems with bugzilla.mozilla.org here" thing should be toned down or
reworded...  I've been noticing Bugzilla bugs showing up in the moz.org product,
too.
(Assignee)

Comment 11

17 years ago
I'll do whatever I can to help. Jake, got any suggestions? We can keep patching
it if it costs you all time. But I suspect that the time thinking about a better
description will out-weigh the time moving bugs to the Browser Product ;)

Comment 12

17 years ago
For bugs in Bugzilla's backend (the code found at
http://lxr.mozilla.org/mozilla/source/webtools/bugzilla). This is not the place
to request configuration changes to this installation of Bugzilla.  If you'd
like to have keywords, components or initial owner/contact information changed,
please file it under the approiate component in the mozilla.org product below.

----
That's my idea, at least... there may be better ones.

As for moving bugs out of the Bugzilla product and into browser, the biggest
issue with that is bug 92594... I'm not sure how I should denote that they
really should be an UNCONFIRMED bugs (I've been putting that in the Status
Whiteboard, but I doubt many ppl pay attention to it :).
Let's go with Jake's suggestion.  I like it.  Here it is again with some minor
changes to make it fit the style of the other products listed around it:

--->
For bugs in the <a href="http://www.mozilla.org/projects/bugzilla">Bugzilla Bug
Tracking System</a> (the code found at <a
href="http://lxr.mozilla.org/mozilla/source/webtools/bugzilla">
http://lxr.mozilla.org/mozilla/source/webtools/bugzilla)</a>. This is not the
place to request configuration changes to this installation of Bugzilla.  If
you'd like to have keywords, components or initial owner/contact information
changed, please file it under the approiate component in the mozilla.org product
below.  If you are here to file a bug in Mozilla, you are most likely looking
for the "Browser" or "MailNews" products.
<---
s/approiate/appropriate/
Take 6:

For bugs in the <a href="http://www.mozilla.org/projects/bugzilla">Bugzilla Bug
Tracking System</a> (the code found at <a
href="http://lxr.mozilla.org/mozilla/source/webtools/bugzilla">
http://lxr.mozilla.org/mozilla/source/webtools/bugzilla)</a>. This is not the
place to request configuration changes to this installation of Bugzilla.  If
you'd like to have keywords, components or initial owner/contact information
changed, please file it under the appropriate component in the mozilla.org
product below.  If you are here to file a bug about the Mozilla web browser
package, you are most likely looking for the "Browser" or "MailNews" products.


That last sentence is optional I guess.  It really doesn't belong here, and only
mentioned because people keep filing Mozilla bugs in Bugzilla :)  The rest of
the cleaning up of the description is a hell of a lot clearer than it used to be
though, so we may be okay without that part.
Take 7:  (had a paren in the wrong place)

For bugs in the <a href="http://www.mozilla.org/projects/bugzilla">Bugzilla Bug
Tracking System</a> (the code found at <a
href="http://lxr.mozilla.org/mozilla/source/webtools/bugzilla">
http://lxr.mozilla.org/mozilla/source/webtools/bugzilla</a>). This is not the
place to request configuration changes to this installation of Bugzilla.  If
you'd like to have keywords, components or initial owner/contact information
changed, please file it under the appropriate component in the mozilla.org
product below.

Comment 17

17 years ago
$c16 =~ s/code/project/; 

Comment 18

17 years ago
r=kiko on the change. no more uppercases please :-)
The boldface was good for the transition period but it's getting stale now. :-)
 Please put this through when you get a chance, thanks!
(Assignee)

Comment 20

17 years ago
done
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 21

17 years ago
vrfy fixed
Status: RESOLVED → VERIFIED
Component: Bugzilla: Keywords & Components → Administration
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.