Closed Bug 978447 Opened 6 years ago Closed 6 years ago

Australis - Bookmarks widget submenu menu item doesn't have an active state

Categories

(Firefox :: Theme, defect)

29 Branch
x86_64
Windows 8.1
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: ntim, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P3])

Attachments

(1 file, 1 obsolete file)

STR :
- Open bookmarks panel
- mousedown on the bookmarks toolbar item

You'll see that there is no active state.
According to the spec, the active state is the same as the hover state for submenu items.
Blocks: 963098
Whiteboard: [Australis:P2]
Component: Menus → Theme
Whiteboard: [Australis:P2] → [Australis:P-]
Whiteboard: [Australis:P-] → [Australis:P3]
On at least OS X the hover style is also missing on checked menu items.
Assignee: nobody → gijskruitbosch+bugs
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Ugh.
Attachment #8386061 - Flags: review?(mdeboer)
Actually, it's just this, because otherwise the hover style overrides the checked style, so perhaps I should just land this...
Attachment #8386062 - Flags: review?(mdeboer)
Attachment #8386061 - Attachment is obsolete: true
Attachment #8386061 - Flags: review?(mdeboer)
Comment on attachment 8386062 [details] [diff] [review]
fix Australis' bookmarks menu hover and active style some more,

Review of attachment 8386062 [details] [diff] [review]:
-----------------------------------------------------------------

Stealing review from Mike, even though I'm totes not a reviewer.  ;)

rs=me.
Attachment #8386062 - Flags: review?(mdeboer) → review+
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/f8b675240214
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 30
Comment on attachment 8386062 [details] [diff] [review]
fix Australis' bookmarks menu hover and active style some more,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 944079
User impact if declined: busted CSS
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none
Attachment #8386062 - Flags: approval-mozilla-aurora?
Attachment #8386062 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.