Fix the remaining Ts regression from bug 970123

RESOLVED FIXED in Firefox 29

Status

defect
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: Ehsan, Assigned: Ehsan)

Tracking

Trunk
mozilla30
Dependency tree / graph

Firefox Tracking Flags

(firefox29+ fixed, firefox30+ fixed)

Details

Attachments

(1 attachment)

Posted patch Patch (v1)Splinter Review
see bug 970123 comment 59.
Attachment #8384202 - Flags: review?(mh+mozilla)
Assignee: nobody → ehsan
Attachment #8384202 - Attachment is patch: true
Comment on attachment 8384202 [details] [diff] [review]
Patch (v1)

Getting nag mail about this, perhaps Benjamin can review faster?
Attachment #8384202 - Flags: review?(benjamin)
Attachment #8384202 - Flags: review?(mh+mozilla)
Attachment #8384202 - Flags: review?(benjamin)
Attachment #8384202 - Flags: review+
Comment on attachment 8384202 [details] [diff] [review]
Patch (v1)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 915735
User impact if declined: startup regression
Testing completed (on m-c, etc.): locally
Risk to taking this patch (and alternatives if risky): zero
String or IDL/UUID changes made by this patch: none
Attachment #8384202 - Flags: approval-mozilla-aurora?
Improvement: Mozilla-Inbound-Non-PGO - Tp5 No Network Row Major MozAfterPaint (Main Startup File IO Bytes) - WINNT 6.1 (ix) - 5.52% decrease
--------------------------------------------------------------------------------------------------------------------------------------------
    Previous: avg 36946166.667 stddev 8142.742 of 12 runs up to revision 85a239cf7dac
    New     : avg 34904941.667 stddev 168371.156 of 12 runs since revision 76a1e5c4c53d
    Change  : -2041225.000 (5.52% / z=250.680)
    Graph   : http://mzl.la/NpwDW0

Changeset range: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=85a239cf7dac&tochange=76a1e5c4c53d

Changesets:
  * http://hg.mozilla.org/integration/mozilla-inbound/rev/76a1e5c4c53d
    : Ehsan Akhgari <ehsan@mozilla.com> - Bug 978509 - Don't preload any of the ICU DLLs, not just the ICU data DLL; r=bsmedberg
    : http://bugzilla.mozilla.org/show_bug.cgi?id=978509
https://hg.mozilla.org/mozilla-central/rev/76a1e5c4c53d
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Attachment #8384202 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.